diff mbox series

[bug#58749] gnu: Add guilescript.

Message ID 87k04q9taj.fsf@pisemsky.com
State New
Headers show
Series [bug#58749] gnu: Add guilescript. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Evgeny Pisemsky Oct. 23, 2022, 8:30 p.m. UTC

Comments

Christopher Baines Nov. 5, 2022, 10:52 a.m. UTC | #1
Evgeny Pisemsky <evgeny@pisemsky.com> writes:

> [1. text/x-patch; 0001-gnu-Add-guilescript.patch]...

Thanks for the patch Evgeny, guilescript looks interesting :)

I've gone ahead and pushed this to master as
2b004b4ed0f1c6b16fa6c8bf0cbb3325538cf398.

Chris
diff mbox series

Patch

From a39aa047301867ff06b957a33a0d8af802c24a4d Mon Sep 17 00:00:00 2001
From: Evgeny Pisemsky <evgeny@pisemsky.com>
Date: Sun, 23 Oct 2022 23:15:16 +0300
Subject: [PATCH] gnu: Add guilescript.

* gnu/packages/guile-xyz.scm (guilescript): New variable.
---
 gnu/packages/guile-xyz.scm | 45 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 209ba694d7..2e7b5431ed 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -44,6 +44,7 @@ 
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
 ;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -264,6 +265,50 @@  (define-public artanis
     (home-page "https://www.gnu.org/software/artanis/")
     (license (list license:gpl3+ license:lgpl3+)))) ;dual license
 
+(define-public guilescript
+  (package
+    (name "guilescript")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/aconchillo/guilescript")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "15bvgklv77kvkl8dizriqblfir6rid5nm79ymi3m2fvpd7wf77qy"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags '("GUILE_AUTO_COMPILE=0")
+       #:modules (((guix build guile-build-system)
+                   #:select (target-guile-effective-version))
+                  ,@%gnu-build-system-modules)
+       #:imported-modules ((guix build guile-build-system)
+                           ,@%gnu-build-system-modules)
+       #:phases (modify-phases %standard-phases
+                  (add-after 'install 'wrap-guilescript
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let* ((out (assoc-ref outputs "out"))
+                             (bin (string-append out "/bin"))
+                             (version (target-guile-effective-version))
+                             (scm (string-append "/share/guile/site/" version))
+                             (go (string-append "/lib/guile/" version "/site-ccache")))
+                        (wrap-program (string-append bin "/guilescript")
+                          `("GUILE_LOAD_PATH" prefix
+                            (,(string-append out scm)))
+                          `("GUILE_LOAD_COMPILED_PATH" prefix
+                            (,(string-append out go)))))
+                      #t)))))
+    (native-inputs (list autoconf automake pkg-config))
+    (inputs (list guile-3.0 bash-minimal))
+    (home-page "https://github.com/aconchillo/guilescript")
+    (synopsis "Guile to JavaScript compiler")
+    (description
+     "GuileScript is a toy compiler that aims to compile Guile to JavaScript.  It
+currently does not do much, but it might in the future.")
+    (license license:gpl3+)))
+
 ;; There are no releases yet of this package.
 (define-public guile-pipe
   (let ((commit "0746ec38d19d844dff0c6f62f209b2b6c8d8872e")

base-commit: 3734857fc55df2c599c2fe5cc4ae49f5d47879fc
-- 
2.38.0