diff mbox series

[bug#59688] gnu: Add zls

Message ID 87k03da8a6.fsf@disroot.org
State New
Headers show
Series [bug#59688] gnu: Add zls | expand

Commit Message

Deslauriers, Douglas via Guix-patches" via Nov. 29, 2022, 7:08 p.m. UTC
Hi,

this is a patch that adds the zls - zig language server. It is not currently
the most recent version, as the project follows versions of zig itself, which
is in guix one version behind. (as zig became self hosted)

Kind regards,
Maya

Comments

Ludovic Courtès Dec. 14, 2022, 11:08 a.m. UTC | #1
Hi Mája,

Mája Tomášek <maya.tomasek@disroot.org> skribis:

> this is a patch that adds the zls - zig language server. It is not currently
> the most recent version, as the project follows versions of zig itself, which
> is in guix one version behind. (as zig became self hosted)

Could you resend the patch to 59688@debbugs.gnu.org using ‘git
send-email’ so that https://qa.guix.gnu.org can pick it up?

> ---
>  gnu/packages/zig-xyz.scm | 70 ++++++++++++++++++++++++++++++++++++++++

Please add the new file to gnu/local.mk.

> +    (synopsis "Zig language server")
> +    (description "Zig Language Server is a language server for the @code{zig} programming language.")

Could you expound the description a bit?  For instance, by mentioning
“Language Server Protocol (LSP)” so that there’s no ambiguity as to the
kind of “language server” we’re talking about?

> +zig-zls

You can remove this line.

Thanks in advance!

Ludo’.
diff mbox series

Patch

---
 gnu/packages/zig-xyz.scm | 70 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 70 insertions(+)
 create mode 100644 gnu/packages/zig-xyz.scm

diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
new file mode 100644
index 0000000000..ff778003cb
--- /dev/null
+++ b/gnu/packages/zig-xyz.scm
@@ -0,0 +1,70 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Maya Tomasek <maya.tomasek@disroot.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages zig-xyz)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix gexp)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages zig)
+  #:use-module (gnu packages python))
+
+(define-public zig-zls
+  (package
+    (name "zig-zls")
+    (version "0.9.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/zigtools/zls")
+                    (commit version)
+                    (recursive? #t)))
+              (sha256
+               (base32 "1hhs7dz9rpshfd1a7x5swmix2rmh53vsqskh3mzqlrj2lgb3cnii"))))
+    (build-system gnu-build-system)
+    (inputs (list zig python))
+    (arguments
+     (list
+      #:modules '((guix build gnu-build-system)
+                  (guix build utils))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (replace 'build
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out"))
+                    (zig (string-append #$zig "/bin/zig")))
+                ;; zig defaults it's cache dir to subdir of $HOME, which is not defined in the build environment
+                (setenv "ZIG_GLOBAL_CACHE_DIR"
+                        (string-append (getcwd) "/zig-cache"))
+                ;; invoke the install target of the build command
+                (invoke zig "build" "install" "-Drelease-safe" "--prefix" out))))
+          (delete 'install)
+          (replace 'check
+            (lambda _
+              (let ((zig (string-append #$zig "/bin/zig")))
+                ;; run the test target
+                (invoke zig "build" "test")))))))
+    (synopsis "Zig language server")
+    (description "Zig Language Server is a language server for the @code{zig} programming language.")
+    (home-page "https://github.com/zigtools/zls")
+    (license license:expat)))
+
+zig-zls
-- 
2.38.1