diff mbox series

[bug#68549] gnu: Add "go-github-com-coreos-go-systemd" sub-packages.

Message ID 87jzo7pwi9.fsf@gmail.com
State New
Headers show
Series [bug#68549] gnu: Add "go-github-com-coreos-go-systemd" sub-packages. | expand

Commit Message

Artyom V. Poptsov Jan. 17, 2024, 7:53 p.m. UTC
Hello,

this patch set adds most of the missing sub-packages for
"go-systemd"[1].

I wasn't able to package "sdjournal" as it requires systemd headers
which are seems to be not present in Guix at the moment.
Thanks,
- avp

References:
1. https://github.com/coreos/go-systemd

Comments

Sharlatan Hellseher Jan. 24, 2024, 12:40 p.m. UTC | #1
Hi,

This patch series adds binding to Systemd which is not provided by Guix.
If they are required for some other packages, please let me know and
I'll review upstream for any workaround(s).

Thanks,
Oleg
Maxim Cournoyer Jan. 24, 2024, 3:09 p.m. UTC | #2
Hi!

"Artyom V. Poptsov" <poptsov.artyom@gmail.com> writes:

> Hello,
>
> this patch set adds most of the missing sub-packages for
> "go-systemd"[1].
>
> I wasn't able to package "sdjournal" as it requires systemd headers
> which are seems to be not present in Guix at the moment.

sdjournal is made available via our elogind package, which extracts the
logind bits of systemd.

Could you please resubmit a v2 version of your patch via git send-email,
it seems QA could not apply it cleanly:
https://qa.guix.gnu.org/issue/68549
Sharlatan Hellseher Feb. 14, 2024, 11:08 p.m. UTC | #3
Hi,

I've removed licenses field from each package as all of them inherited
from the same source and placed them in golang-xyz.

Pushed as 30afb17152..9ddb59f452 to master.

--
Oleg
Maxim Cournoyer Feb. 16, 2024, 7:52 p.m. UTC | #4
Hi,

help-debbugs@gnu.org (GNU bug Tracking System) writes:

> Your bug report
>
> #68549: [PATCH] gnu: Add "go-github-com-coreos-go-systemd" sub-packages.
>
> which was filed against the guix-patches package, has been closed.
>
> The explanation is attached below, along with your original report.
> If you require more details, please reply to 68549@debbugs.gnu.org.
>
> -- 
> 68549: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=68549
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
>
> From: Sharlatan Hellseher <sharlatanus@gmail.com>
> Subject: [PATCH] gnu: Add "go-github-com-coreos-go-systemd" sub-packages.
> To: 68549-done@debbugs.gnu.org
> Date: Wed, 14 Feb 2024 23:08:14 +0000 (1 day, 20 hours, 43 minutes ago)
>
>
> Hi,
>
> I've removed licenses field from each package as all of them inherited
> from the same source and placed them in golang-xyz.
>
> Pushed as 30afb17152..9ddb59f452 to master.

Thank you, Oleg!
diff mbox series

Patch

From c193b9a4b34b4f63ff57c7990aea160f0f443998 Mon Sep 17 00:00:00 2001
Message-ID: <c193b9a4b34b4f63ff57c7990aea160f0f443998.1705520948.git.poptsov.artyom@gmail.com>
In-Reply-To: <790fc4be076e488bbbfcecd2dffba66bf884cf99.1705520948.git.poptsov.artyom@gmail.com>
References: <790fc4be076e488bbbfcecd2dffba66bf884cf99.1705520948.git.poptsov.artyom@gmail.com>
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Wed, 17 Jan 2024 22:48:36 +0300
Subject: [PATCH 6/6] gnu: Add go-github-com-coreos-go-systemd-unit.

* gnu/packages/golang.scm (go-github-com-coreos-go-systemd-unit): New
  variable.

Change-Id: I4103a0a8a3fe8f0efe4e21b053cecda9825efdc1
---
 gnu/packages/golang.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5c2c2eb407..a2d697bebd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9345,6 +9345,22 @@  (define-public go-github-com-coreos-go-systemd-machine1
     (description "Go bindings to systemd for registering machines/containers.")
     (license license:asl2.0)))
 
+(define-public go-github-com-coreos-go-systemd-unit
+  (package
+    (inherit go-github-com-coreos-go-systemd-activation)
+    (name "go-github-com-coreos-go-systemd-unit")
+    (arguments
+     '(#:tests? #f ;Tests require D-Bus daemon running.
+       #:import-path "github.com/coreos/go-systemd/unit"
+       #:unpack-path "github.com/coreos/go-systemd"))
+    (native-inputs (list go-github-com-godbus-dbus))
+    (home-page "https://github.com/coreos/go-systemd")
+    (synopsis "Go bindings to systemd for working with unit files")
+    (description
+     "Go bindings to systemd for (de)serialization and comparison of unit
+files.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-emirpasic-gods
   (package
     (name "go-github-com-emirpasic-gods")
-- 
2.41.0