[bug#76571,04/15] gnu: python-multiprocessing-on-dill: Use pyproject-build-system.

Message ID 87jz9dwhex.fsf@ngraves.fr
State New
Headers
Series Some fixes |

Commit Message

Nicolas Graves Feb. 24, 2025, 7 a.m. UTC
  * gnu/packages/python-xyz.scm (python-multiprocessing-on-dill): Use pyproject-build-system.
[arguments]: Remove field.
[native-inputs]: Remove uneeded python-check-manifest. Add python-pytest.
---
 gnu/packages/python-xyz.scm | 12 ++----------
 1 file changed, 2 insertions(+), 10 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6cf0862eed..a5eefb8be2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30207,17 +30207,9 @@  (define-public python-multiprocessing-on-dill
               (sha256
                (base32
                 "1rs5a3hx1fcpfsxxkl5kx6g06c82wqjqgdqyny5l1ggl1wq0rmfn"))))
-    (build-system python-build-system)
-    (arguments
-     (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-vv")))))))
+    (build-system pyproject-build-system)
     (propagated-inputs (list python-dill))
-    (native-inputs (list python-check-manifest python-pytest python-wheel))
+    (native-inputs (list python-pytest python-setuptools python-wheel))
     (home-page "https://github.com/sixty-north/multiprocessing_on_dill")
     (synopsis "Multiprocessing using dill instead of pickle")
     (description