[bug#33849] gnu: Add polybar

Message ID 87imzkfe3g.fsf@gmail.com
State Accepted
Headers show
Series [bug#33849] gnu: Add polybar | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Meiyo Peng Dec. 23, 2018, 3:38 p.m. UTC
Hi,

This patch adds polybar to Guix. A beautiful and flexible status bar.

Comments

Ludovic Courtès Dec. 23, 2018, 5:41 p.m. UTC | #1
Hello,

Meiyo Peng <meiyo.peng@gmail.com> skribis:

>>From e5871eaba91a1d5909fbc0ffcea767244204f644 Mon Sep 17 00:00:00 2001
> From: Meiyo Peng <meiyo.peng@gmail.com>
> Date: Sun, 23 Dec 2018 23:05:38 +0800
> Subject: [PATCH] gnu: Add polybar.
>
> * gnu/packages/wm.scm (polybar): New variable.

[...]

> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/jaagr/polybar/releases/"
> +                           "download/" version "/polybar.tar"))
> +       (sha256
> +        (base32 "1zpsvh1n77bx7s6mqqh3ba828k9xbp35c2mjmcl9nywfp6r5ldqi"))
> +       (file-name (string-append name "-" version ".tar"))))

Please use ‘git-fetch’ rather than downloading a generated tarball (it’s
a generated tarball, right?).

> +    (build-system cmake-build-system)
> +    (arguments
> +     ;; Test is disabled because it requires downloading googletest from the
> +     ;; Internet.
> +     '(#:tests? #f))

Did you try adding ‘googletest’ to ‘native-inputs’, and perhaps also
disabling the code that tries to download it?

The rest LGTM!  Could you send an updated patch?

Thank you,
Ludo’.

Patch

From e5871eaba91a1d5909fbc0ffcea767244204f644 Mon Sep 17 00:00:00 2001
From: Meiyo Peng <meiyo.peng@gmail.com>
Date: Sun, 23 Dec 2018 23:05:38 +0800
Subject: [PATCH] gnu: Add polybar.

* gnu/packages/wm.scm (polybar): New variable.
---
 gnu/packages/wm.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2e211e389..062790141 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -76,6 +76,7 @@ 
   #:use-module (gnu packages lua)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages suckless)
+  #:use-module (gnu packages mpd)
   #:use-module (guix download)
   #:use-module (guix git-download))
 
@@ -1051,3 +1052,45 @@  its size
 @item Display preview images in a tiled icon layout
 @end itemize")
     (license license:gpl2+)))
+
+(define-public polybar
+  (package
+    (name "polybar")
+    (version "3.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/jaagr/polybar/releases/"
+                           "download/" version "/polybar.tar"))
+       (sha256
+        (base32 "1zpsvh1n77bx7s6mqqh3ba828k9xbp35c2mjmcl9nywfp6r5ldqi"))
+       (file-name (string-append name "-" version ".tar"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; Test is disabled because it requires downloading googletest from the
+     ;; Internet.
+     '(#:tests? #f))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("cairo" ,cairo)
+       ("i3-wm" ,i3-wm)
+       ("libmpdclient" ,libmpdclient)
+       ("libnl" ,libnl)
+       ("libxcb" ,libxcb)
+       ("pulseaudio" ,pulseaudio)
+       ("xcb-proto" ,xcb-proto)
+       ("xcb-util" ,xcb-util)
+       ("xcb-util-cursor" ,xcb-util-cursor)
+       ("xcb-util-image" ,xcb-util-image)
+       ("xcb-util-wm" ,xcb-util-wm)
+       ("xcb-util-xrm" ,xcb-util-xrm)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python-2" ,python-2)           ; lib/xpp depends on python 2
+       ("python" ,python)))             ; xcb-proto depends on python 3
+    (home-page "https://polybar.github.io/")
+    (synopsis "Fast and easy-to-use status bar")
+    (description "Polybar aims to help users build beautiful and highly
+customizable status bars for their desktop environment.  It has built-in
+functionality to display information about the most commonly used services.")
+    (license license:expat)))
-- 
2.20.0