diff mbox series

[bug#36538] gnu: dosfstools: Enable compat symlinks.

Message ID 87imsehvt7.fsf@gmx.com
State Accepted
Headers show
Series [bug#36538] gnu: dosfstools: Enable compat symlinks. | expand

Commit Message

Pierre Langlois July 7, 2019, 12:29 p.m. UTC
Hello Guix!

Here's a quick patch to dosfstools to include commands such 'mkfs.vfat',
'fsck.vfat', ...etc

Thanks!
Pierre

Comments

Ludovic Courtès July 8, 2019, 10:58 a.m. UTC | #1
Pierre Langlois <pierre.langlois@gmx.com> skribis:

>>From 56376f9538ee6c333a92caccfc9eef626d499df0 Mon Sep 17 00:00:00 2001
> From: Pierre Langlois <pierre.langlois@gmx.com>
> Date: Sun, 7 Jul 2019 13:25:08 +0100
> Subject: [PATCH] gnu: dosfstools: Enable compat symlinks.
>
> Enable compatibility symlinks to provide commands such as `mkfs.vfat`.
>
> * gnu/packages/disk.scm (dosfstools)[arguments]: Pass
> "--enable-compat-symlinks" to configure.

Applied, thanks!

Ludo'.
diff mbox series

Patch

From 56376f9538ee6c333a92caccfc9eef626d499df0 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Sun, 7 Jul 2019 13:25:08 +0100
Subject: [PATCH] gnu: dosfstools: Enable compat symlinks.

Enable compatibility symlinks to provide commands such as `mkfs.vfat`.

* gnu/packages/disk.scm (dosfstools)[arguments]: Pass
"--enable-compat-symlinks" to configure.
---
 gnu/packages/disk.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 06f4430b2d..187ef74b4e 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -236,7 +237,8 @@  to recover data more efficiently by only reading the necessary blocks.")
          "0wy13i3i4x2bw1hf5m4fd0myh61f9bcrs035fdlf6gyc1jksrcp6"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags (list (string-append "PREFIX=" %output)
+     `(#:configure-flags (list "--enable-compat-symlinks")
+       #:make-flags (list (string-append "PREFIX=" %output)
                           "CC=gcc")))
     (native-inputs
      `(("xxd" ,xxd))) ; for tests
-- 
2.22.0