diff mbox series

[bug#36467,v2] gnu: Add some Common Lisp libraries

Message ID 87imr7rak9.fsf@yamatai
State Accepted
Headers show
Series [bug#36467,v2] gnu: Add some Common Lisp libraries | expand

Commit Message

Guillaume Le Vaillant Aug. 8, 2019, 2:33 p.m. UTC
Updated and rebased patches attached. I also reordered them, which
should reduce the number of merge conflicts if the 'lisp.scm' file
changes before they are applied.

Comments

Ludovic Courtès Sept. 4, 2019, 1:35 p.m. UTC | #1
Hello Guillaume,

Guillaume Le Vaillant <glv@posteo.net> skribis:

> Updated and rebased patches attached. I also reordered them, which
> should reduce the number of merge conflicts if the 'lisp.scm' file
> changes before they are applied.

Katherine, Pierre, or Andy: could you take care of these patches and
push those that you deem ready?

  https://issues.guix.gnu.org/issue/36467

Thanks in advance!  :-)

Ludo’.
Pierre Neidhardt Sept. 16, 2019, 8:55 a.m. UTC | #2
Hi Guillaume,

thanks for the big patchset, looking very good overall!

A few general nits:

- You didn't define any "ecl-" package.  Could you define them for all the
  packages (unless they are known to be broken with ECL)?
  I know some packages lack the ecl- definition, this should be fixed :p

- 6 commit messages lack a period on the first line.
  If you use Emacs, you might find this yasnippet useful:
  guix/etc/snippets/text-mode/guix-commit-message-add-package

fprog:
  - Description should start with a capital, or here maybe with @code{fprog}.

cambl:
  - is spelled in all-caps ("CAMBL") according to the README.

cl-containers:
  - synopsis: "Container library ..."

  - I'm realizing the sbcl-lift does not have the right version number, which
    should be (git-version "1.7.1" ...).  Can you update this?

bst:
  - 1.1 is out ;)

cl-octet-streams:
  - Description should start with a capital, or here maybe with @code{cl-octet-streams}.

cl-lzlib
  - License seems to be GPL-3, not GPL-3+, but since this is your library, the
    decision is all yours ;)

Thanks a lot for this great contribution to "Common Lisp on Guix" :)
diff mbox series

Patch

From c5fde4eb376cfa75127418ef68bc755ada2c3e0d Mon Sep 17 00:00:00 2001
From: Guillaume LE VAILLANT <glv@posteo.net>
Date: Mon, 1 Jul 2019 23:23:22 +0200
Subject: [PATCH 12/12] gnu: Add cl-lzlib

* gnu/packages/lisp.scm (sbcl-lzlib, cl-lzlib): New variables.
---
 gnu/packages/lisp.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d4858245ec..385aa35002 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6998,3 +6998,45 @@  libraries.")
 
 (define-public cl-octet-streams
   (sbcl-package->cl-source-package sbcl-cl-octet-streams))
+
+(define-public sbcl-lzlib
+  (let ((commit "0de1db7129fef9a58a059d35a2fa2ecfc5b47b47")
+        (revision "1"))
+    (package
+      (name "sbcl-lzlib")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/glv2/cl-lzlib.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "12ny7vj52fgnd8hb8fc8mry92vq4c1x72x2350191m4476j95clz"))))
+      (build-system asdf-build-system/sbcl)
+      (native-inputs
+       `(("fiveam" ,sbcl-fiveam)))
+      (inputs
+       `(("cffi" ,sbcl-cffi)
+         ("cl-octet-streams" ,sbcl-cl-octet-streams)
+         ("lzlib" ,lzlib)))
+      (arguments
+       '(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'fix-paths
+             (lambda* (#:key inputs #:allow-other-keys)
+               (substitute* "src/lzlib.lisp"
+                 (("liblz\\.so")
+                  (string-append (assoc-ref inputs "lzlib") "/lib/liblz.so")))
+               #t)))))
+      (synopsis "Common Lisp library for lzip (de)compression")
+      (description
+       "This Common Lisp library provides functions for lzip (LZMA)
+compression/decompression using bindings to the lzlib C library.")
+      (home-page "https://github.com/glv2/cl-lzlib")
+      (license license:gpl3+))))
+
+(define-public cl-lzlib
+  (sbcl-package->cl-source-package sbcl-lzlib))
-- 
2.22.0