diff mbox series

[bug#40191] mesa: Support rockchip platforms

Message ID 87imivbt46.fsf@yucca
State Accepted
Headers show
Series [bug#40191] mesa: Support rockchip platforms | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Vagrant Cascadian March 23, 2020, 4:19 a.m. UTC
The attached patch enables drivers in mesa which should allow some
aarch64/armhf rockchip platforms (e.g. veyron-speedy, pinebook pro) to
make use of gpu acceleration.

I haven't thoroughly tested this patch yet, but it does at least build
and produces an appropriate dri library!

There are almost 2000 dependent packages on mesa, so this probably needs
though core-updates according to current recommendations... I haven't
tried rebuilding all the dependent packages? FWIW, I *think* it will
only trigger a rebuild on aarch64/armhf.


live well,
  vagrant

Comments

Marius Bakke March 29, 2020, 8:13 p.m. UTC | #1
Vagrant Cascadian <vagrant@debian.org> writes:

> The attached patch enables drivers in mesa which should allow some
> aarch64/armhf rockchip platforms (e.g. veyron-speedy, pinebook pro) to
> make use of gpu acceleration.

Awesome!  :-)

> I haven't thoroughly tested this patch yet, but it does at least build
> and produces an appropriate dri library!

Sounds good.

> There are almost 2000 dependent packages on mesa, so this probably needs
> though core-updates according to current recommendations... I haven't
> tried rebuilding all the dependent packages? FWIW, I *think* it will
> only trigger a rebuild on aarch64/armhf.

Indeed.  We are just about to start the core-updates branch, so this
patch came just in time.  LGTM, please push!
Vagrant Cascadian March 29, 2020, 10 p.m. UTC | #2
On 2020-03-29, Marius Bakke wrote:
> Vagrant Cascadian <vagrant@debian.org> writes:
>
>> The attached patch enables drivers in mesa which should allow some
>> aarch64/armhf rockchip platforms (e.g. veyron-speedy, pinebook pro) to
>> make use of gpu acceleration.
>
> Awesome!  :-)
>
>> I haven't thoroughly tested this patch yet, but it does at least build
>> and produces an appropriate dri library!
>
> Sounds good.
>
>> There are almost 2000 dependent packages on mesa, so this probably needs
>> though core-updates according to current recommendations... I haven't
>> tried rebuilding all the dependent packages? FWIW, I *think* it will
>> only trigger a rebuild on aarch64/armhf.
>
> Indeed.  We are just about to start the core-updates branch, so this
> patch came just in time.  LGTM, please push!

Pushed to core-updates!


live well,
  vagrant
diff mbox series

Patch

From d7c810c1a5b306439a47263ab294398d1382ecbe Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Sun, 22 Mar 2020 16:32:33 +0000
Subject: [PATCH] gnu: mesa: Enable rockchip support on aarch64/armhf.

* gnu/packages/gl (mesa): Enable kmsro, lima and panfrost gallium drivers.
---
 gnu/packages/gl.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 01241cd88e..710c602a96 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -293,7 +293,7 @@  also known as DXTn or DXTC) for Mesa.")
        '(,@(match (%current-system)
              ((or "armhf-linux" "aarch64-linux")
               ;; TODO: Fix svga driver for aarch64 and armhf.
-              '("-Dgallium-drivers=etnaviv,freedreno,nouveau,r300,r600,swrast,tegra,v3d,vc4,virgl"))
+              '("-Dgallium-drivers=etnaviv,freedreno,kmsro,lima,nouveau,panfrost,r300,r600,swrast,tegra,v3d,vc4,virgl"))
              (_
               '("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
          ;; Enable various optional features.  TODO: opencl requires libclc,
-- 
2.20.1