diff mbox series

[bug#41405] Update emacs-magit to latest commit.

Message ID 87imgral9n.fsf@gmail.com
State Accepted
Headers show
Series [bug#41405] Update emacs-magit to latest commit. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Maxim Cournoyer May 19, 2020, 5:26 p.m. UTC
This updates our emacs-magit package to the latest version, which
has the following benefits:

1) The test suite is now enabled.
2) The libgit2 C library is now accelerating some of the Magit tasks
3) Using the emacs-build-system means the Magit autoload file is
now byte compiled.
4) No custom patching is done.

The other updates were required to prevent breaking some of the packages
which had a dependency on emacs-magit.

Maxim

Comments

Nicolas Goaziou May 26, 2020, 9:53 p.m. UTC | #1
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> This updates our emacs-magit package to the latest version, which
> has the following benefits:
>
> 1) The test suite is now enabled.
> 2) The libgit2 C library is now accelerating some of the Magit tasks
> 3) Using the emacs-build-system means the Magit autoload file is
> now byte compiled.
> 4) No custom patching is done.
>
> The other updates were required to prevent breaking some of the packages
> which had a dependency on emacs-magit.

LGTM!

Regards,
Maxim Cournoyer May 27, 2020, 5:49 p.m. UTC | #2
Hi,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Hello,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> This updates our emacs-magit package to the latest version, which
>> has the following benefits:
>>
>> 1) The test suite is now enabled.
>> 2) The libgit2 C library is now accelerating some of the Magit tasks
>> 3) Using the emacs-build-system means the Magit autoload file is
>> now byte compiled.
>> 4) No custom patching is done.
>>
>> The other updates were required to prevent breaking some of the packages
>> which had a dependency on emacs-magit.
>
> LGTM!

Thanks for the review!  I pushed the series to master with commit
ffd2696bd8c898cb69b8b443db5584d84986d419.

Maxim
diff mbox series

Patch

From 0dc89992266fcfcd3ebd93f2a7f2e16eaa14e388 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Tue, 19 May 2020 11:55:17 -0400
Subject: [PATCH 5/5] gnu: emacs-forge: Update to commit 09bf8ad.

* gnu/packages/emacs-xyz.scm (emacs-forge): Update to 09bf8ad.
[native-inputs]: Remove emacs-minimal, which is implicitly provided by the
emacs-build-system.
---
 gnu/packages/emacs-xyz.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5be5c097e3..733b8ca7af 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19265,10 +19265,10 @@  commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
       (license license:gpl3+))))
 
 (define-public emacs-forge
-  (let ((commit "63cbf81f166fc71861d8e3d246df8e5ccedcb9bb"))
+  (let ((commit "09bf8adc9c9afb492632e612f51f39e1cc15fca0"))
     (package
       (name "emacs-forge")
-      (version (git-version "0.1.0" "3" commit))
+      (version (git-version "0.1.0" "4" commit))
       (source
        (origin
          (method git-fetch)
@@ -19278,11 +19278,10 @@  commands (a prefix and a suffix) we prefer to call it just a \"transient\".")
          (file-name (git-file-name name version))
          (sha256
           (base32
-           "1yf2xjx3459py6rji740jm8bmh2pv66ghnbjxsvjd4jf9kcdav83"))))
+           "148h1rvmfmxyrfy2q5l0vzblr7lpsyw1si30hfwhzsj8fvj21qcr"))))
       (build-system emacs-build-system)
       (native-inputs
-       `(("texinfo" ,texinfo)
-         ("emacs" ,emacs-minimal)))
+       `(("texinfo" ,texinfo)))
       (propagated-inputs
        `(("emacs-closql" ,emacs-closql)
          ("emacs-dash" ,emacs-dash)
-- 
2.26.2