diff mbox series

[bug#41551] gnu: Add emacs-bm.

Message ID 87imgixo1a.fsf@rohleder.de
State Accepted
Headers show
Series [bug#41551] gnu: Add emacs-bm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Michael Rohleder May 26, 2020, 11:41 p.m. UTC

Comments

Marius Bakke May 30, 2020, 11:50 a.m. UTC | #1
Michael Rohleder <mike@rohleder.de> writes:

> From edd01faf84a59499a9a83b336d55828aadd6bfa3 Mon Sep 17 00:00:00 2001
> From: Michael Rohleder <mike@rohleder.de>
> Date: Wed, 27 May 2020 01:37:42 +0200
> Subject: [PATCH] gnu: Add emacs-bm.
>
> * gnu/packages/emacs-xyz.scm (emacs-bm): New variable.

Thanks!  It LGTM but no longer applies, can you rebase it on the current
master branch?
  
> +(define-public emacs-bm
> +  (package
> +    (name "emacs-bm")
> +    (version "201905")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/joodland/bm.git")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "180b3rc13asrmsdh7v405d54jkrininvaj52xhp71vw91ng51dkn"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/joodland/bm")
> +    (synopsis "Visual Bookmarks for Emacs")
                        ^^^
              Lowercase 'b'.

> +    (description "This package provides visible, buffer local, bookmarks and
> +the ability to jump forward and backward to the next bookmark.")

The description reads a bit weird, I wonder if...

  "visible, buffer local bookmarks" (without the second comma)

...is more correct?

Can you send an updated patch?
diff mbox series

Patch

From edd01faf84a59499a9a83b336d55828aadd6bfa3 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Wed, 27 May 2020 01:37:42 +0200
Subject: [PATCH] gnu: Add emacs-bm.

* gnu/packages/emacs-xyz.scm (emacs-bm): New variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b99acb7815..34afc73d8e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1860,6 +1860,26 @@  code@{emacs-wiki.el}, it facilitates using hyperlinks and doing full-text
 searches.  Unlike code@{emacs-wiki.el}, it can be combined with any format.")
     (license license:gpl1+)))
 
+(define-public emacs-bm
+  (package
+    (name "emacs-bm")
+    (version "201905")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/joodland/bm.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "180b3rc13asrmsdh7v405d54jkrininvaj52xhp71vw91ng51dkn"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/joodland/bm")
+    (synopsis "Visual Bookmarks for Emacs")
+    (description "This package provides visible, buffer local, bookmarks and
+the ability to jump forward and backward to the next bookmark.")
+    (license license:gpl2+)))
+
 (define-public emacs-calfw
   (package
     (name "emacs-calfw")
-- 
2.26.2