diff mbox series

[bug#41459,2/4] gnu: Add python-pytest-benchmark

Message ID 87img9dcpj.fsf@alice.lan
State Accepted
Headers show
Series [bug#41459] gnu: Add python-flask-restx | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Edouard Klein June 2, 2020, 9:44 a.m. UTC
* gnu/packages/python-check.scm (python-pytest-benchmark): New variable.
---
 gnu/packages/python-check.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Marius Bakke June 22, 2020, 7:36 p.m. UTC | #1
Edouard Klein <edk@beaver-labs.com> writes:

> * gnu/packages/python-check.scm (python-pytest-benchmark): New variable.

Applied with this minor change:

     (description
-     "This pytest fixture will group the tests into rounds that are calibrated to
-the chosen timer.")
+     "This package provides a pytest fixture that will group the tests into
+rounds that are calibrated to the chosen timer.")
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1071abdbad..b13b750bbd 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -360,6 +360,30 @@  framework.")
 for the @code{pytest} framework.")
     (license license:expat)))
 
+(define-public python-pytest-benchmark
+  (package
+    (name "python-pytest-benchmark")
+    (version "3.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-benchmark" version))
+       (sha256
+        (base32
+         "0a4mpb4j73dsyk47hd1prrjpfk4r458s102cn80rf253jg818hxd"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-py-cpuinfo" ,python-py-cpuinfo)))
+    (native-inputs
+     `(("python-pathlib2" ,python-pathlib2)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/ionelmc/pytest-benchmark")
+    (synopsis "Pytest fixture for benchmarking code")
+    (description
+     "This pytest fixture will group the tests into rounds that are calibrated to
+the chosen timer.")
+    (license license:bsd-2)))
+
 (define-public python-codacy-coverage
   (package
     (name "python-codacy-coverage")