diff mbox series

bug#40492: [PATCH] gnu: Add meshlab

Message ID 87imfv108a.fsf@gnu.org
State Accepted
Headers show
Series bug#40492: [PATCH] gnu: Add meshlab | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès June 13, 2020, 2:58 p.m. UTC
Hi,

Ekaitz Zarraga <ekaitz@elenq.tech> skribis:

> From 2779f50ad71b4458272aaa9223df96e3a77f60e4 Mon Sep 17 00:00:00 2001
> From: Ekaitz Zarraga <ekaitz@elenq.tech>
> Date: Fri, 12 Jun 2020 23:41:18 +0200
> Subject: [PATCH] gnu: Add meshlab.
>
> * gnu/packages/engineering.scm (meshlab): New variable.

Alright!  Applied with the following changes (whitespace-insensitive
diff).  I hope we can eventually fix the qhull issue, we’ll see.

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index b243974dcc..fe3c87edd5 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2622,20 +2622,20 @@  export filters.")
     (license license:lgpl2.1+)))
 
 (define-public meshlab
-  (let ((version "2020.05"))
   (package
     (name "meshlab")
-      (version version)
+    (version "2020.05")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/cnr-isti-vclab/meshlab")
                     (commit (string-append "Meshlab-" version))
                     (recursive? #t)))
+              (file-name (git-file-name name version))
               (sha256
                (base32 "00sim20ka9vjwljixdj4cqd285j21mpaq05ari7nqq2w8yyglp5m"))))
     (build-system cmake-build-system)
-      (native-inputs
+    (inputs
      `(("qtbase" ,qtbase)
        ("qtscript" ,qtscript)
        ("qtxmlpatterns" ,qtxmlpatterns)
@@ -2648,20 +2648,17 @@  export filters.")
        ("libfreenect" ,libfreenect)
        ("lib3ds" ,lib3ds)
        ("openctm" ,openctm)
-         ;; Compilation fails with system qhull
+       ;; FIXME: Compilation fails with system qhull:
        ;; https://github.com/cnr-isti-vclab/meshlab/issues/678
        ;; ("qhull" ,qhull)
        ))
     (arguments
      `(#:tests? #f                                ; Has no tests
        #:phases
-         (modify-phases
-             %standard-phases
-           (add-after
-               'unpack 'go-to-source-dir
+       (modify-phases %standard-phases
+         (add-after 'unpack 'go-to-source-dir
            (lambda _ (chdir "src") #t))
-           (add-after
-               'install 'move-files
+         (add-after 'install 'move-files
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((lib (string-append (assoc-ref outputs "out")
                                        "/lib")))
@@ -2679,4 +2676,4 @@  rendering and converting this kind of meshes.  These tools include MeshLab
 proper, a versatile program with a graphical user interface, and meshlabserver,
 a program that can perform mesh processing tasks in batch mode, without a
 GUI.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))