diff mbox series

[bug#41881] Add BurgerSpace

Message ID 87imfscak9.fsf@nicolasgoaziou.fr
State Accepted
Headers show
Series [bug#41881] Add BurgerSpace | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Nicolas Goaziou June 15, 2020, 8:56 p.m. UTC
Hello,

The following add flatzebra game engine and BurgerSpace.

Regards,

Comments

Nicolas Goaziou June 28, 2020, 11:04 p.m. UTC | #1
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> The following add flatzebra game engine and BurgerSpace.

Applied. Closing.
diff mbox series

Patch

From bf559b567493c26093a681d81d4feb3a942b3add Mon Sep 17 00:00:00 2001
From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Date: Mon, 15 Jun 2020 21:56:36 +0200
Subject: [PATCH 2/2] gnu: Add burgerspace.

* gnu/packages/games.scm (burgerspace): New variable.
---
 gnu/packages/games.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 10ac8cb550..fc19c25c85 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10560,6 +10560,33 @@  soldiers, jeeps and tanks.  The gameplay is simple but it is not that easy to
 get high scores.")
     (license license:gpl2+)))
 
+(define-public burgerspace
+  (package
+    (name "burgerspace")
+    (version "1.9.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://perso.b2b2c.ca/~sarrazip/dev/"
+                           "burgerspace-" version ".tar.gz"))
+       (sha256
+        (base32 "1005a04rbn4lzjrpfg0m394k2mfaji63fm2qhdqdsxila8a6kjbv"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("flatzebra" ,flatzebra)))
+    (home-page "http://perso.b2b2c.ca/~sarrazip/dev/burgerspace.html")
+    (synopsis "Avoid evil foodstuffs and make burgers")
+    (description
+     "This is a clone of the classic game BurgerTime.  In it, you play
+the part of a chef who must create burgers by stepping repeatedly on
+the ingredients until they fall into place.  And to make things more
+complicated, you also must avoid evil animate food items while
+performing this task, with nothing but your trusty pepper shaker to
+protect you.")
+    (license license:gpl2+)))
+
 (define-public 7kaa
   (package
     (name "7kaa")
-- 
2.26.2