diff mbox series

[bug#42526] gnu: Add emacs-shx.

Message ID 87imecgvvz.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#42526] gnu: Add emacs-shx. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph July 25, 2020, 2:40 a.m. UTC
Patch file is attached.

--
Joseph LaFreniere

Comments

Oleg Pykhalov July 25, 2020, 8:12 a.m. UTC | #1
Hi,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> writes:

> Patch file is attached.

Could you also take a look on running test suite in a package recipe,
please?

Thanks,
Oleg.
diff mbox series

Patch

From c653ac4e2cb4f70a9c02ce99f2f45539c566daad Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Fri, 24 Jul 2020 21:38:06 -0500
Subject: [PATCH] gnu: Add emacs-shx.

* gnu/packages/emacs-xyz.scm (emacs-shx): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 836a3950f8..6843f3470f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3918,6 +3918,34 @@  the speedbar window.")
      "This package provides commands to quickly switch between shell buffers.")
     (license license:gpl3+)))
 
+(define-public emacs-shx
+  (package
+    (name "emacs-shx")
+    (version "1.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/riscy/shx-for-emacs")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "0p9b621rgy34r1hl9xfzxh4xpx9gpsr3n330ypfxhlr0s5754j73"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; A docstring provides examples of mapping hosts to programs in /bin.
+         ;; These examples are valid as-is.
+         (delete 'patch-el-files))))
+    (home-page "https://github.com/riscy/shx-for-emacs")
+    (synopsis "Extras for the comint-mode shell")
+    (description
+     "This package extends @code{comint-mode}: it parses markup in the output
+stream, enabling plots and graphics to be embedded, and adds command-line
+functions which plug into Emacs (e.g. use @code{:e <filename>} to edit a
+file).")
+    (license license:gpl3+)))
+
 (define-public emacs-names
   (let ((commit "d8baba5360e5253938a25d3e005455b6d2d86971")
         (version "20151201.0")
-- 
2.27.0