diff mbox series

[bug#42549] gnu: Add emacs-standard-dirs.

Message ID 87ime7s0qv.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#42549] gnu: Add emacs-standard-dirs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph July 28, 2020, 11:01 p.m. UTC
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
> I suggest to eschew the problem and stick to the first sentence 
> of the
> description:
>
>   This package provides platform-specific paths for reading and 
>   writing
>   configuration, cache, and other data.
>
> I think this is enough to understand what the package is about 
> without
> looking at the gory details.
>
> WDYT?

Sounds good to me.  A new patch file is attached with the 
description updated.

--
Joseph LaFreniere

Comments

Ludovic Courtès Sept. 19, 2020, 8:39 p.m. UTC | #1
Hi,

"LaFreniere, Joseph" <joseph@lafreniere.xyz> skribis:

>>From 9ba21584daa8a62bf939162dbd91ccb706f75f0f Mon Sep 17 00:00:00 2001
> From: Joseph LaFreniere <joseph@lafreniere.xyz>
> Date: Sun, 26 Jul 2020 11:06:19 -0500
> Subject: [PATCH] gnu: Add emacs-standard-dirs.
>
> * gnu/packages/emacs-xyz.scm (emacs-standard-dirs): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 9ba21584daa8a62bf939162dbd91ccb706f75f0f Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Sun, 26 Jul 2020 11:06:19 -0500
Subject: [PATCH] gnu: Add emacs-standard-dirs.

* gnu/packages/emacs-xyz.scm (emacs-standard-dirs): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8aaa92e1b2..f74fa948e4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3592,6 +3592,30 @@  particular, the minor mode works quite well with Org or Markdown modes, or
 other markup language major modes.")
       (license license:gpl3+))))
 
+(define-public emacs-standard-dirs
+  (package
+    (name "emacs-standard-dirs")
+    (version "2.0.0")
+    (home-page "https://github.com/lafrenierejm/standard-dirs.el")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0r814qcrhvx4qlx4sdzwdmrhiryslqclx0bnpp0qcrbx6g8qfl25"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-f" ,emacs-f)
+       ("emacs-s" ,emacs-s)))
+    (synopsis "Platform-specific paths for config, cache, and other data")
+    (description
+     "This package provides platform-specific paths for reading and writing
+configuration, cache, and other data.")
+    (license license:gpl3+)))
+
 (define-public emacs-string-inflection
   (package
     (name "emacs-string-inflection")
-- 
2.27.0