diff mbox series

[bug#43930] gnu: Add emacs-graphql-mode.

Message ID 87imbgofzz.fsf@asu.edu
State Accepted
Headers show
Series [bug#43930] gnu: Add emacs-graphql-mode. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

John Soo Oct. 11, 2020, 4:59 p.m. UTC
Hi Guix,

I've been writing some graphql recently and graphql-mode has been
invaluable.

Thanks!

John

Comments

Nicolas Goaziou Oct. 13, 2020, 7:15 a.m. UTC | #1
Hello,

John Soo <jsoo1@asu.edu> writes:

> I've been writing some graphql recently and graphql-mode has been
> invaluable.

Thank you. Some comments follow.

> +(define-public emacs-graphql-mode
> +  (let ((commit "9bed568ec86242dbe30bdbab324aa0eb2cd9bf08")

Could you add a comment explaining why you don't use a tagged commit
(in this case, there is none)?

> +        (revision "1"))
> +    (package
> +      (name "emacs-graphql-mode")
> +      (version commit)
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/davazp/graphql-mode")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> +           "0x9y7qq6y0zg8ncamzvk68ccmdyzh7xsj0xs0ykyl20d5wdpplj4"))))

Nitpick: please move the string on the same line as `base32'.

> +      (build-system emacs-build-system)
> +      (home-page
> +       "https://github.com/davazp/graphql-mode")

Nitpick: please move the string on the same line as `home-page'.

> +      (synopsis "Emacs mode to edit GraphQL schema and queries")
> +      (description
> +       "This package provides an Emacs mode for editing graphql queries and
> +schemas.")

I suggest to expound the description a bit. For example, using
commentary section of the library, it could be something along the lines
of:

    This package implements a major mode to edit GraphQL schemas and
    query. The basic functionality includes syntax highlight and
    indentation. Additionally, it is able to send GraphQL queries to an
    end-point URL.

    Files with the @file{.graphql} and @file{.gql} extensions are
    automatically opened with this mode.


Could you send an updated patch?

Regards,
diff mbox series

Patch

From b1203ce58608f70de97c9cf44f53eef026c60bf4 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Tue, 29 Sep 2020 09:58:05 -0700
Subject: [PATCH] gnu: Add emacs-graphql-mode.

* gnu/packages/emacs-xyz.scm (emacs-graphql-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fca4c22569..612248ad96 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -765,6 +765,31 @@  GraphQL is a data query language and runtime designed and used to request and
 deliver data to mobile and web apps.")
     (license license:gpl3+)))
 
+(define-public emacs-graphql-mode
+  (let ((commit "9bed568ec86242dbe30bdbab324aa0eb2cd9bf08")
+        (revision "1"))
+    (package
+      (name "emacs-graphql-mode")
+      (version commit)
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/davazp/graphql-mode")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0x9y7qq6y0zg8ncamzvk68ccmdyzh7xsj0xs0ykyl20d5wdpplj4"))))
+      (build-system emacs-build-system)
+      (home-page
+       "https://github.com/davazp/graphql-mode")
+      (synopsis "Emacs mode to edit GraphQL schema and queries")
+      (description
+       "This package provides an Emacs mode for editing graphql queries and
+schemas.")
+      (license license:gpl3+))))
+
 (define-public emacs-ghub
   (package
     (name "emacs-ghub")
-- 
2.28.0