diff mbox series

[bug#43990] gnu: emacs-with-editor: Update to 2.9.4-1.c4768f51.

Message ID 87imbdnfon.fsf@rohleder.de
State Accepted
Headers show
Series [bug#43990] gnu: emacs-with-editor: Update to 2.9.4-1.c4768f51. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Michael Rohleder Oct. 14, 2020, 12:40 p.m. UTC
Testing an updated version of emacs-next with lot's of packages.  Looks
very good, except magit, where one can't commit anything.

Comments

Nicolas Goaziou Oct. 15, 2020, 9:59 p.m. UTC | #1
Hello,

Michael Rohleder <mike@rohleder.de> writes:

> Subject: [PATCH] gnu: emacs-with-editor: Update to 2.9.4-1.c4768f51.

Applied. Thank you.

Regards,
diff mbox series

Patch

>From ea4cca33d754dd4679cb8bc9ad46a700805f62fe Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Wed, 14 Oct 2020 11:57:32 +0200
Subject: [PATCH] gnu: emacs-with-editor: Update to 2.9.4-1.c4768f51.

* gnu/packages/emacs-xyz.scm (emacs-with-editor): Update to 2.9.4-1.c4768f51.
---
 gnu/packages/emacs-xyz.scm | 44 +++++++++++++++++++++-----------------
 1 file changed, 24 insertions(+), 20 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cc97e051d0..284ecf8f25 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -383,29 +383,33 @@  configuration files, such as .gitattributes, .gitignore, and .git/config.")
     (license license:gpl3+)))
 
 (define-public emacs-with-editor
-  (package
-    (name "emacs-with-editor")
-    (version "2.9.4")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/magit/with-editor")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1z3214zjf3dassb31k14gq4nbr3q8g5x87ydfah28hm4j08v0wb3"))))
-    (build-system emacs-build-system)
-    (propagated-inputs
-     `(("emacs-dash" ,emacs-dash)))
-    (home-page "https://github.com/magit/with-editor")
-    (synopsis "Emacs library for using Emacsclient as EDITOR")
-    (description
-     "This package provides an Emacs library to use the Emacsclient as
+  ;; This commit fixes an (magit) issue with emacs 28, see
+  ;; https://lists.gnu.org/archive/html/help-gnu-emacs/2020-10/msg00211.html
+  (let ((commit "c4768f51c7415119519b4626d8643d60e584098c")
+        (revision "1"))
+    (package
+      (name "emacs-with-editor")
+      (version (git-version "2.9.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/magit/with-editor")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "01ysb9pnscpmingay6njdywkqgj4hn5l5d9igsg3x7p7061jwwix"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-dash" ,emacs-dash)))
+      (home-page "https://github.com/magit/with-editor")
+      (synopsis "Emacs library for using Emacsclient as EDITOR")
+      (description
+       "This package provides an Emacs library to use the Emacsclient as
 @code{$EDITOR} of child processes, making sure they know how to call home.
 For remote processes a substitute is provided, which communicates with Emacs
 on stdout instead of using a socket as the Emacsclient does.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-libgit
   (let ((commit "0ef8b13aef011a98b7da756e4f1ce3bb18e4d55a")
-- 
2.28.0