diff mbox series

[bug#45457] gnu: Add emacs-keycast

Message ID 87im8n2zfp.fsf@gmail.com
State Accepted
Headers show
Series [bug#45457] gnu: Add emacs-keycast | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

André A. Gomes Dec. 27, 2020, 12:42 p.m. UTC
Hi Guix!

Comments

Nicolas Goaziou Dec. 28, 2020, 4:49 p.m. UTC | #1
Hello,

André Alexandre Gomes <andremegafone@gmail.com> writes:

> Subject: [PATCH] gnu: Add emacs-keycast.
>
> gnu/packages/emacs-xyz.scm (emacs-keycast): New variable.

Applied (elsewhere than at the end of the file…). Thank you!

Regards,
diff mbox series

Patch

From ba5c1f2f04510f0a2831e6cca668385026c0c819 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andr=C3=A9=20Alexandre=20Gomes?= <andremegafone@gmail.com>
Date: Sun, 27 Dec 2020 15:40:45 +0300
Subject: [PATCH] gnu: Add emacs-keycast.

gnu/packages/emacs-xyz.scm (emacs-keycast): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0822bfdd29..60cb884226 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26100,3 +26100,26 @@  to pastebin-like services.  It supports more than one service and will
 failover if one service fails.  More services can easily be added over time
 and prefered services can easily be configured.")
     (license license:gpl3+)))
+
+(define-public emacs-keycast
+  (package
+    (name "emacs-keycast")
+    (version "1.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tarsius/keycast.git")
+             (commit (string-append "v" version))))
+       (file-name
+        (git-file-name name version))
+       (sha256
+        (base32 "1g9arjdhdpvsw47ny9gi5k758ya37yza4mr0rhbf02yvrqyfsrgr"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/tarsius/keycast")
+    (synopsis "Show current command and its key in the mode line")
+    (description
+     "This package provides Keycast mode.  Once enabled, that mode shows
+the current command and its key or mouse binding in the mode line, and
+updates them whenever another command is invoked.")
+    (license license:gpl3+)))
-- 
2.29.2