diff mbox series

[bug#48128] Add font-montserrat.

Message ID 87im43wlcl.fsf@colimite.fr
State Accepted
Headers show
Series [bug#48128] Add font-montserrat. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Sergiu Ivanov April 30, 2021, 8:47 p.m. UTC
Dear Guix,

Here's a patch adding the font Montserrat.

I retrieve the release zipball from GitHub using a direct url-fetch
rather than git-fetch, because I've seen both in fonts.scm. If you think
git-fetch is more appropriate, I'll change the method.

Thank you!

Comments

Ludovic Courtès May 3, 2021, 4:13 p.m. UTC | #1
Hi Sergiu,

Sergiu Ivanov <sivanov@colimite.fr> skribis:

> I retrieve the release zipball from GitHub using a direct url-fetch
> rather than git-fetch, because I've seen both in fonts.scm. If you think
> git-fetch is more appropriate, I'll change the method.


[...]

> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://github.com/JulietaUla/Montserrat/archive/refs/tags/v" version ".zip"))

This is a generated tarball that may change over time, which is why
‘guix lint’ warns about it.  So yes, I think you should use ‘git-fetch’
instead.

You’ll also have to add a ‘file-name’ field to the origin, as ‘guix
lint’ suggests.

There are also a couple of ‘guix lint’ warnings that I’ll let you
check.  :-)

> +    (synopsis "The Montserat font")
                            ^
Missing ‘r’.

Could you send an updated patch?

Thanks in advance,
Ludo’.
diff mbox series

Patch

From 6de396df2fa096e8ff3e27328c902fe789e12a13 Mon Sep 17 00:00:00 2001
From: Sergiu Ivanov <sivanov@colimite.fr>
Date: Fri, 30 Apr 2021 22:20:16 +0200
Subject: [PATCH] Add font-montserrat.

---
 gnu/packages/fonts.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b78c46b0f8..35f2398dc8 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -39,6 +39,7 @@ 
 ;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
 ;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
+;;; Copyright © 2021 Sergiu Ivanov <sivanov@colimite.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2156,3 +2157,21 @@  suitable for a wide range of uses.")
     (description "Cozette is a 6x13px (bounding box) bitmap font based on Dina
 and heavily inspired by Creep.")
     (license license:expat)))
+
+(define-public font-montserrat
+  (package
+    (name "font-montserrat")
+    (version "7.210")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/JulietaUla/Montserrat/archive/refs/tags/v" version ".zip"))
+              (sha256
+               (base32
+                "0k5jsb8hgya4ap80w5l4vxnx17kw482k3lm007awjyy5qzp982z3"))
+              ))
+    (build-system font-build-system)
+    (home-page "https://github.com/JulietaUla/Montserrat")
+    (synopsis "The Montserat font")
+    (description "The old posters and signs in the traditional Montserrat neighborhood of Buenos Aires inspired Julieta Ulanovsky to design this typeface and rescue the beauty of urban typography that emerged in the first half of the twentieth century.")
+    (license license:silofl1.1)))
-- 
2.31.1