diff mbox series

[bug#48126] Add package for vim-solarized

Message ID 87im43qs01.fsf@nckx
State Accepted
Headers show
Series [bug#48126] Add package for vim-solarized | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Tobias Geerinckx-Rice April 30, 2021, 11:20 p.m. UTC
Tissevert 写道:
> I here's my first attempt at packaging something, I noticed that 
> vim-solarized
> was missing so I tried to write a package for it.

Thank you!

>
> The only warning I got was from the guix lint which told me it 
> couldn't find
> upstream releases. I believe this is due to vim-solarized 
> particular structure:
> it's a light «clone» of the main repository
> https://github.com/altercation/solarized containing only the 
> vim-files.

Hmm.  Could we install from this authoritative(?) source instead, 
even if the download's bigger?

> (https://github.com/vim-scripts/Solarized) which has made a tag 
> (the same
> version name that I chose) so we could be using either the full 
> repository
> (more unneeded data retrieved during the build) or this second 
> copy (they do
> provide a tag but isn't it better to remain as close as possible 
> to the
> original source ?).

Oh, I think we agree.  :-)

/tmp λ git clone --depth=1 
https://github.com/vim-scripts/Solarized
Cloning into 'Solarized' [...]
/tmp λ git clone --depth=1 
https://github.com/altercation/solarized
Cloning into 'solarized' [...]
/tmp λ du -hs [Ss]olarized
196K	Solarized
30M	solarized

The relative difference is huge but I think 30M is worth it.

Could you make this change, test, and send a V2?  I'm no adherent 
of the Vim.

> I hope my patch is correct and thank you everyone for being such 
> a welcoming
> community and having made my experience with Guix so far 
> absolutely great !

Thank you!  We try to do our best...

Your patch is great.  I'd make the following tweaks before 
committing.  You can incorporate them into your V2 if you want.

The description should explain what the package is to someone 
who's never heard of it.  We actually recommend ~10 lines (more is 
fine), although many existing packages don't meet that bar.  The 
synopsis should do the same in one line.

Don't be afraid to temper fawning upstream marketing-speak and 
empty taglines like this one.  That doesn't mean it can't be 
positive (like mine -- I hate Solarized).

C-M-q reindented the source field according to the same rules as 
etc/indent-code.el.  Better to do so before committing it, so 
future committers can just run C-M-q on the entire expression 
without creating unrelated whitespace noise.

+sunlight and can tire the eye.  Solarized reduces brightness 
contrast but,
+unlike many low-contrast color schemes, retains contrasting hues 
based on
+color wheel relations for syntax highlighting readability.
+
+Solarized retains the same selective contrast relationships and 
overall feel
+when switching between the light and dark background modes.")
+    (license license:expat)))

Kind regards,

T G-R

Comments

Tobias Geerinckx-Rice April 30, 2021, 11:27 p.m. UTC | #1
Well that diff got börked to hell.  Here it is again.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 477c15b9aa..ad95724c41 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -585,24 +585,33 @@  are detected, the user is notified.")
     (name "vim-solarized")
     (version "v1.0.0beta1")
     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url 
                "https://github.com/altercation/vim-colors-solarized")
-               (commit 
                "528a59f26d12278698bb946f8fb82a63711eec21")))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
- 
           "05d3lmd1shyagvr3jygqghxd3k8a4vp32723fvxdm57fdrlyzcm1"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url 
"https://github.com/altercation/vim-colors-solarized")
+             (commit 
"528a59f26d12278698bb946f8fb82a63711eec21")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 
"05d3lmd1shyagvr3jygqghxd3k8a4vp32723fvxdm57fdrlyzcm1"))))
     (build-system copy-build-system)
     (arguments
      '(#:install-plan
        '(("colors" "share/vim/vimfiles/")
          ("doc" "share/vim/vimfiles/"))))
     (home-page 
     "https://github.com/altercation/vim-colors-solarized")
-    (synopsis "Solarized Colorscheme for Vim")
-    (description "Precision colors for machines and people")
-    (license license:bsd-3)))
+    (synopsis "Solarized color scheme for Vim")
+    (description
+     "Solarized is a sixteen-color palette of eight monotones and 
eight accent
+colors.  It was designed for use with both terminal and GUI 
applications.
+
+Black text on white from a computer display is akin to reading a 
book in direct