diff mbox series

[bug#48817] gnu: Add emacs-kibit-helper.

Message ID 87im2ud6nv.fsf@posteo.net
State Accepted
Headers show
Series [bug#48817] gnu: Add emacs-kibit-helper. | expand

Commit Message

Aleksandr Vityazev June 3, 2021, 8:39 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-kibit-helper): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Nicolas Goaziou June 5, 2021, 11:52 a.m. UTC | #1
Hello,

Alexandr Vityazev <avityazev@posteo.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-kibit-helper): New variable.

Thank you. I applied your patch, with the changes mentioned below. 

> +(define-public emacs-kibit-helper
> +  (let ((version "0.1.1")
> +        (revision "0")
> +        (commit "16bdfff785ee05d8e74a5780f6808506d990cef7"))

I targeted exact "0.1.1" release instead.  The commit you use is just
three commits above it, which only apply to the README file.

> +      (synopsis
> +       "Conveniently use the Kibit Leiningen plugin from Emacs")

I removed the "conveniently" buzzword.

> +      (description
> +       "Provides functions that make it easy to work with the Kibit
> +Leiningen plugin for detecting and improving non-idiomatic
> +Clojure source code, from within GNU Emacs. ")

The description must use full sentences, so I reworded it a bit. Also,
there was a trailing white space at its end.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d145e8e16b..7d985c0d0f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28244,3 +28244,31 @@  shorter than usual, using mostly unprefixed keys.")
    (description "@code{emacs-multitran} is a zero-dependency Emacs interface
 to the https://multitran.com online dictionary.")
    (license license:gpl3+)))
+
+(define-public emacs-kibit-helper
+  (let ((version "0.1.1")
+        (revision "0")
+        (commit "16bdfff785ee05d8e74a5780f6808506d990cef7"))
+    (package
+      (name "emacs-kibit-helper")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/brunchboy/kibit-helper")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0s2hb2lvfmcvm3n1fg4biaafc1p7j7w990d7w15gicaw6rr2j4nr"))))
+      (build-system emacs-build-system)
+      (propagated-inputs `(("emacs-s" ,emacs-s)))
+      (home-page
+       "http://www.github.com/brunchboy/kibit-helper")
+      (synopsis
+       "Conveniently use the Kibit Leiningen plugin from Emacs")
+      (description
+       "Provides functions that make it easy to work with the Kibit
+Leiningen plugin for detecting and improving non-idiomatic
+Clojure source code, from within GNU Emacs. ")
+      (license license:gpl3+))))