diff mbox series

[bug#55271] gnu: Fix emacs-git-email

Message ID 87ilqkqiam.fsf@posteo.net
State Accepted
Headers show
Series [bug#55271] gnu: Fix emacs-git-email | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Niklas Eklund May 5, 2022, 12:24 p.m. UTC
Hi,

the emacs-git-email package unfortunately doesn't build due to an error
in the upstream repository. This patch patches the package so it build
properly.

Best regards,
Niklas Eklund

Comments

Ludovic Courtès May 8, 2022, 9:27 p.m. UTC | #1
Hi,

Niklas Eklund <niklas.eklund@posteo.net> skribis:

>>From 03f1d320cb34b830af7d2536f08ceb73c17791ac Mon Sep 17 00:00:00 2001
> From: Niklas Eklund <niklas.eklund@posteo.net>
> Date: Thu, 5 May 2022 13:10:56 +0200
> Subject: [PATCH] gnu: emacs-git-email: Fixes build of package.
>
> The git-email-mu4e.el contains unbalanced parens upstream. This commit patches
> the source code to avoid failures when building emacs-git-email.

I adjusted the patch file name as suggested by ‘guix lint’, added a
conventional commit log, and committed.

Thanks,
Ludo’.
diff mbox series

Patch

From 03f1d320cb34b830af7d2536f08ceb73c17791ac Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Thu, 5 May 2022 13:10:56 +0200
Subject: [PATCH] gnu: emacs-git-email: Fixes build of package.

The git-email-mu4e.el contains unbalanced parens upstream. This commit patches
the source code to avoid failures when building emacs-git-email.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/emacs-xyz.scm                    |  2 ++
 ...fix-missing-parens-in-git-email-mu4e.patch | 27 +++++++++++++++++++
 3 files changed, 30 insertions(+)
 create mode 100644 gnu/packages/patches/emacs-fix-missing-parens-in-git-email-mu4e.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 44d20de57d..cc9fae4b3e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1027,6 +1027,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/elm-compiler-fix-map-key.patch		\
   %D%/packages/patches/elogind-revert-polkit-detection.patch	\
   %D%/packages/patches/emacs-exec-path.patch			\
+  %D%/packages/patches/emacs-fix-missing-parens-in-git-email-mu4e.patch			\
   %D%/packages/patches/emacs-fix-scheme-indent-function.patch	\
   %D%/packages/patches/emacs-ignore-empty-xim-styles.patch	\
   %D%/packages/patches/emacs-json-reformat-fix-tests.patch	\
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a928ac72f1..1e83abcf9d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15759,6 +15759,8 @@  (define-public emacs-git-email
          (uri (git-reference
                (url "https://git.sr.ht/~yoctocell/git-email")
                (commit commit)))
+         (patches
+          (search-patches "emacs-fix-missing-parens-in-git-email-mu4e.patch"))
          (file-name (git-file-name name version))
          (sha256
           (base32 "1lk1yds7idgawnair8l3s72rgjmh80qmy4kl5wrnqvpmjrmdgvnx"))))
diff --git a/gnu/packages/patches/emacs-fix-missing-parens-in-git-email-mu4e.patch b/gnu/packages/patches/emacs-fix-missing-parens-in-git-email-mu4e.patch
new file mode 100644
index 0000000000..051e2bf1eb
--- /dev/null
+++ b/gnu/packages/patches/emacs-fix-missing-parens-in-git-email-mu4e.patch
@@ -0,0 +1,27 @@ 
+From 820ad7eb2e919e3f880bec22bd4f737fa55c4d22 Mon Sep 17 00:00:00 2001
+From: Niklas Eklund <niklas.eklund@posteo.net>
+Date: Thu, 5 May 2022 12:43:49 +0200
+Subject: [PATCH] Fix missing parens in git-email-mu4e.el
+
+The incorrect number of parens in this file lead to Emacs failing to
+parse the file.
+---
+ git-email-mu4e.el | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/git-email-mu4e.el b/git-email-mu4e.el
+index d5b8770..9220bf9 100644
+--- a/git-email-mu4e.el
++++ b/git-email-mu4e.el
+@@ -51,7 +51,7 @@ from Lisp, enable the mode if ARG is omitted or nil."
+                ;; built in context feature.
+                (seq-filter (lambda (header)
+                              (not (eq (car header) 'from)))
+-                           headers)
++                           headers))))
+     (setq git-email-compose-email-function 'message-mail)))
+ 
+ (provide 'git-email-mu4e)
+-- 
+2.34.0
+
-- 
2.34.0