diff mbox series

[bug#56140,Patches] Add and update music packages

Message ID 87ilog68o3.fsf@elephly.net
State New
Headers show
Series [bug#56140,Patches] Add and update music packages | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ricardo Wurmus July 1, 2022, 5:29 p.m. UTC
Hi,

I slightly modified the patches as discussed on IRC.

I’m not sure about what to do with the last patch of the series, the one
adding distrho-ports.  This package bundles a bunch of other libraries
and the license situation is not clear.  I just spot checked one or two
plugins and their licenses do not appear in the license field so I’d
prefer to have some more eyes on this and see if things can be unbundled
some more.

Below is my modified package definition.

Comments

Thorsten Wilms July 1, 2022, 6:05 p.m. UTC | #1
On Fri, 01 Jul 2022 19:29:17 +0200
Ricardo Wurmus <rekado@elephly.net> wrote:

> I’m not sure about what to do with the last patch of the series, the one
> adding distrho-ports.  This package bundles a bunch of other libraries
> and the license situation is not clear.  I just spot checked one or two
> plugins and their licenses do not appear in the license field so I’d
> prefer to have some more eyes on this and see if things can be unbundled
> some more.

When I had a go at packaging distrho-ports, I took notes about the
licensing situation and asked about it on the list. Issues include
total lack of licensing information, licensing info only upstream,
upstream unavailable due to DMCA takedwon.

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=49224

---
non-copyleft for drow (MIT). agpl3 for HiReSam.

Just no license info for arctican-function, artican-pilgrim and vex.

No license info found in the repo, but found by following the URL
given in each source/JucePluginCharacteristics.h:
- ports-legacy/HiReSam ->
https://github.com/klangfreund/SpectrumAnalyser: GPL2+ or Affero
GPL3
- ports-legacy/drowaudio-common ->
https://github.com/drowaudio/drowaudio: MIT. Plus LGPL2.1 for
included Soundtouch, which I found no mention of in DISTRHO-Ports
sources. Also mentions separate license for FFTReal, which I also
see no mention of in DISTRHO-Ports sources.
- ports-legacy/easySSP ->
https://github.com/automatl/audio-dsp-multi-visualize/: GPL3.
- ports-legacy/juce-opl -> https://bsutherland.github.io/JuceOPLVSTi/
-> https://github.com/bsutherland/JuceOPLVSTi: GPL2.
- ports/legacyluftikus ->
https://code.google.com/archive/p/lkjb-plugins/: GPL2.
- ports-legacy/pitchedDelay ->
https://code.google.com/archive/p/lkjb-dc12/: GPL2.
- ports-legacy/refine -> https://github.com/lkjbdsp/lkjb-plugins#ReFine:
MIT. Strangely, this repo also includes PitchedDelay and Luftikus,
presented elsewhere as GPL2.
- ports-legacy/stereosourceseparation ->
https://github.com/laixinyuan/StereoSourceSepartion: Repository
unavailable due to DMCA takedown. According to falkTX, this is due
Steinberg having something against distribution of the VST2 SDK,
which is not included in the DISTRHO-Ports version.
- ports-legacy/temper -> https://github.com/creativeintent/temper:
GPL3.
- ports-legacy/wolpertinger -> https://tumbetoene.tuxfamily.org/
-> https://tumbetoene.tuxfamily.org/index.php?entry=entry110926-112345
-> download readme: GPL2+.
---
diff mbox series

Patch

From be138ba5b9898654cf935f6828ae53a8211ff634 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Fri, 1 Jul 2022 17:55:37 +0200
Subject: [PATCH] gnu: Add distrho-ports.

* gnu/packages/music.scm (distrho-ports): New variable.
---
 gnu/packages/music.scm | 63 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 63 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cc9bae5612..297748e39e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6019,6 +6019,69 @@  (define-public mamba
 ones.")
    (license license:bsd-0)))
 
+(define-public distrho-ports
+  (package
+    (name "distrho-ports")
+    (version "0.2021-03-15")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/DISTRHO/DISTRHO-Ports")
+                    ;; This commit corresponds to tag 2021-03-15
+                    (commit "fe5bf2e87dd440ba98d3e8ac647b8518e2851f74")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0a0i5ajqww8zpgrgpr1n4r2418l2sakvdz9y7pjwnx8168kmlmpl"))))
+    (build-system meson-build-system)
+    (inputs
+     (list fftwf
+           alsa-lib
+           freetype
+           libx11
+           libxrender
+           libxext
+           libxcursor
+           mesa))
+    (native-inputs
+     (list pkg-config
+           cmake-minimal))
+    (home-page "https://github.com/DISTRHO/DISTRHO-Ports")
+    (synopsis "Audio plugins and LV2 ports")
+    (description
+     "This package contains LV2 ports of the following plugins:
+@itemize
+@item The Function,
+@item The Pilgrim,
+@item Dexed,
+@item dRowAudio plugins (Distortion, Distortion Shaper, Flanger, Reverb,
+  Tremolo),
+@item DrumSynth,
+@item EasySSP,
+@item EQinox,
+@item HiReSam,
+@item JuceOPL,
+@item KlangFalter,
+@item LUFS Meter,
+@item LUFS Meter (Multichannel),
+@item Luftikus,
+@item Obxd,
+@item PitchedDelay,
+@item ReFine,
+@item StereoSourceSeperation,
+@item Swanky Amp,
+@item TAL plugins (Dub-3, Filter, Filter-2, Noize Mak3r, Reverb, Reverb-II,
+  Reverb-III, Vocoder-II),
+@item Temper,
+@item Vex,
+@item Vitalium, and
+@item Wolpertinger.
+@end itemize
+")
+    ;; This package consists of several plugins.
+    ;; Different copyrights and licenses apply to different plugins.
+    (license (list license:gpl2 license:lgpl3))))
+
 (define-public dpf-plugins
   (package
     (name "dpf-plugins")
-- 
2.36.1