[bug#61139] Subject: [PATCH v2] gnu: emacs-next: Enable tree-sitter support.
Commit Message
Hey Luis
>
> Revision numbers start at 0 if I'm not mistaken.
>
Good to know. Thanks.
>
> Is there any reason for tree-sitter to be added as a propagated
> input? It does not provide any binaries and I tested changing it
> to a normal input and c-ts-mode worked fine.
>
Wired. I tried to put it in the =inputs= earlier today, Emacs failed to
find tree-sitter. But it works now. I guess I did something wrong before.
Regards,
Declan
Comments
Hi Declan,
tried your newest patch and it LGTM. The only problem I see now is
that your copyright's year is wrong haha.
Regards,
From 1d91c374a325ad8be799cadeb77b4b976b8fbce9 Mon Sep 17 00:00:00 2001
From: Declan Tsien <declantsien@riseup.net>
Date: Sun, 29 Jan 2023 13:34:03 +0800
Subject: [PATCH] gnu: emacs-next: Enable tree-sitter support.
* gnu/packages/emacs.scm (emacs-next): Update to 29.0.60-0.2bd0b94.
* gnu/packages/emacs.scm (emacs-next)[inputs]: Add tree-sitter.
---
gnu/packages/emacs.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)
@@ -23,6 +23,7 @@
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2022 Declan Tsien <declantsien@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@ (define-module (gnu packages emacs)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages text-editors) ; for tree-sitter
#:use-module (gnu packages web) ; for jansson
#:use-module (gnu packages webkit)
#:use-module (gnu packages xml)
@@ -381,12 +383,12 @@ (define* (emacs-byte-compile-directory dir)
(license license:gpl3+)))
(define-public emacs-next
- (let ((commit "6adc193ad66445acd84caba6973424ecbd21da26")
- (revision "4"))
+ (let ((commit "2bd0b9475384adfb4dd2cc794bbe1d8621546717")
+ (revision "0"))
(package
(inherit emacs)
(name "emacs-next")
- (version (git-version "29.0.50" revision commit))
+ (version (git-version "29.0.60" revision commit))
(source
(origin
(inherit (package-source emacs))
@@ -401,10 +403,10 @@ (define-public emacs-next
"emacs-native-comp-driver-options.patch"))
(sha256
(base32
- "0b48qg9w7fzvhva78gzi3cs2m6asj11fk0kgys49fqhwskigzg1f"))))
+ "0pf2qlbfddpzp38x6rpz0qpadwa3vgrp3dik3a4wr3cdcby98cc3"))))
(inputs
(modify-inputs (package-inputs emacs)
- (prepend sqlite)))
+ (prepend sqlite tree-sitter)))
(native-inputs
(modify-inputs (package-native-inputs emacs)
(prepend autoconf))))))
base-commit: bea22409682f6d1947de7d92f264aad822c2e68c
--
2.39.1