diff mbox series

[bug#62286] Proposed addition (nntpit)

Message ID 87ilewpp8y.fsf@fastmail.com
State New
Headers show
Series [bug#62286] Proposed addition (nntpit) | expand

Commit Message

James March 19, 2023, 6:31 p.m. UTC
From 2c21874666c2dd57b816631083911065c5b0b328 Mon Sep 17 00:00:00 2001
From: Jim Taylor <james.taylor@fastmail.com>
Date: Sun, 19 Mar 2023 13:19:30 -0500
Subject: [PATCH] Add nntpit to 'web' packages

---
 gnu/packages/web.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Nicolas Goaziou April 2, 2023, 8:34 p.m. UTC | #1
Hello,

James <james.taylor@fastmail.com> writes:

> Subject: [PATCH] Add nntpit to 'web' packages

I wrote a proper commit message and applied your patch. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7b05a99752..90337b8dd8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6510,6 +6510,32 @@  (define-public python-clf
 snippets on @url{https://commandlinefu.com}.")
       (license license:expat))))
 
+(define-public nntpit
+  (let ((commit "c0d654736460d174a680b2e06c3a81ce883fc09a")
+        (revision "0"))
+    (package
+      (name "nntpit")
+      (version (git-version "0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/taviso/nntpit")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1kkdh2qpkfw97hzw9jsxy5jzmhhv8261bj63mvr5c9qwlp6qs46g"))))
+      (build-system gnu-build-system)
+      (native-inputs (list autoconf automake glib pkg-config))
+      (inputs (list curl json-c libev))
+      (synopsis "Minimal reddit2nntp gateway server")
+      (description
+       "This is a simple reddit2nntp gateway server that lets you use a newsreader
+ to follow discussions on reddit.  The intention is for you to run it locally,
+ tell your newsreader to connect to localhost, and subreddits will appear as newsgroups!")
+      (home-page "https://github.com/taviso/nntpit")
+      (license license:expat))))
+
 (define-public rss-bridge
   (package
     (name "rss-bridge")