diff mbox series

[bug#62684] gnu: Zstandard: Update to 1.5.5.

Message ID 87ile8klqf.fsf@gmail.com
State New
Headers show
Series [bug#62684] gnu: Zstandard: Update to 1.5.5. | expand

Commit Message

Simon Tournier April 7, 2023, 10:52 a.m. UTC
Hi Leo,

On mer., 05 avril 2023 at 15:26, Leo Famulari <leo@famulari.name> wrote:

> +    (replacement zstd-1.5.5)
>      (version "1.5.0")

[...]

> +(define-public zstd-1.5.5
> +  (package
> +    (inherit zstd)
> +    (version "1.5.5")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append "https://github.com/facebook/zstd/releases/download/"
> +                           "v" version "/zstd-" version ".tar.gz"))
> +       (sha256
> +        (base32 "1r1ydmj7ib3g5372yj3k40vl3b9ax0154qg2lqcy7ylwhb69chww"))))))

I am always confused by the implication of such change.

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix show zstd | recsel -p name,version
name: zstd
version: 1.5.5

name: zstd
version: 1.5.0

$ ./pre-inst-env guix build zstd@1.5.0
/gnu/store/g8cl62bmsdsqn14yxghdl882zn0ls8n9-zstd-1.5.5-lib
/gnu/store/b980xf8i6qmx7iaih1bfnqvaihg37p3b-zstd-1.5.5
/gnu/store/6iysnbm6rb9hm61f7jsqgiry5l9v9yca-zstd-1.5.5-static

$ ./pre-inst-env guix build zstd@1.5.0 --no-grafts
/gnu/store/3x3dl71d4xm6y4hjwq110hmfyfx0xc6j-zstd-1.5.0-lib
/gnu/store/bn6pk5zjjdpdfzb6yfr5psi9pji9w51n-zstd-1.5.0
/gnu/store/wa5pngf2lywgi8vd8k9b1k13wp2acvi4-zstd-1.5.0-static
--8<---------------cut here---------------end--------------->8---

Well, maybe something like:

--8<---------------cut here---------------start------------->8---
--8<---------------cut here---------------end--------------->8---

would be less confusing.

Note this discussion [1] about similar examples.  And this patch [2] as
an attempt to address the UX issue.

1: https://yhetil.org/guix/86czvohn86.fsf@gmail.com/
2: https://yhetil.org/guix/86im5a6ea4.fsf@gmail.com

Cheers,
simon

Comments

Leo Famulari April 8, 2023, 5:07 p.m. UTC | #1
On Fri, Apr 07, 2023 at 12:52:40PM +0200, Simon Tournier wrote:
> Well, maybe something like:
[...]
> +    (properties `((hidden? . #true)))

Yes, thank you. Please see version 2 of the patch.

I tried using the HIDDEN-PACKAGE procedure for zstd@1.5.0. It doesn't
change the derivation, which is good, but I don't know how to un-hide
the replacement. So this is good enough, I think.
diff mbox series

Patch

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 8a78fee107..5841ea0cf0 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1637,6 +1637,7 @@  (define-public zstd
     (name "zstd")
     (replacement zstd-1.5.5)
     (version "1.5.0")
+    (properties `((hidden? . #true)))
     (source
      (origin
        (method url-fetch)
@@ -1726,6 +1727,7 @@  (define-public zstd-1.5.5
   (package
     (inherit zstd)
     (version "1.5.5")
+    (properties '())
     (source
      (origin
        (method url-fetch)