diff mbox series

bug#62373: [PATCH] gnu: Add python-pdoc.

Message ID 87ilbotm20.fsf@gnu.org
State New
Headers show
Series bug#62373: [PATCH] gnu: Add python-pdoc. | expand

Commit Message

Ludovic Courtès June 15, 2023, 10:09 p.m. UTC
Hi Ontje,

<Ontje.Luensdorf@dlr.de> skribis:

> From 8a6adf3add637fd3d04fa2dee3b413f5dd65fd06 Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Ontje=20L=C3=BCnsdorf?= <ontje.luensdorf@dlr.de>
> Date: Wed, 22 Mar 2023 09:42:09 +0100
> Subject: [PATCH] gnu: Add python-pdoc.
>
> * gnu/packages/python-xyz.scm (python-pdoc): New variable.

Sorry for the long delay.  Applied with the minor changes below.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0c98701146..cdffc3ad67 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1070,16 +1070,15 @@  (define-public python-pdoc
   (package
     (name "python-pdoc")
     (version "13.0.1")
-    (source
-      (origin
-        (method git-fetch)
-        (uri
-         (git-reference
-          (url "https://github.com/mitmproxy/pdoc")
-          (commit (string-append "v" version))))
-        (sha256
-          (base32
-           "0gxkw607nrd67ck4w8jri9vfrm5g60qvp8b134m8zkiphbxjnx0l"))))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mitmproxy/pdoc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0gxkw607nrd67ck4w8jri9vfrm5g60qvp8b134m8zkiphbxjnx0l"))))
     (build-system pyproject-build-system)
     (native-inputs (list python-pytest python-jinja2 python-pygments))
     (arguments
@@ -1091,13 +1090,12 @@  (define-public python-pdoc
                                  "not test_smoke[mock] and "
                                  "not test_snapshots[html"))))
     (home-page "https://pdoc.dev/")
-    (synopsis "API Documentation for Python Projects")
+    (synopsis "API documentation for Python projects")
     (description "pdoc auto-generates API documentation that follows your
 project's Python module hierarchy.  It requires no configuration, has
 first-class support for type annotations, cross-links between identifiers,
 comes with an integrated live-reloading web server, uses customizable HTML
-templates, understands numpydoc and Google-style docstrings, and is
-permissively licensed.")
+templates, understands numpydoc and Google-style docstrings.")
     (license license:unlicense)))
 
 (define-public python-py4j