diff mbox series

bug#58356: [PATCH] Add xtrlock

Message ID 87il9dvbvw.fsf_-_@gnu.org
State New
Headers show
Series bug#58356: [PATCH] Add xtrlock | expand

Commit Message

Ludovic Courtès Aug. 17, 2023, 5:04 p.m. UTC
Hi,

Mehmet Tekman <mtekman89@gmail.com> skribis:

> From aced8b924a194495233b0698f2185b9b80d10963 Mon Sep 17 00:00:00 2001
> From: Mehmet Tekman <mtekman89@gmail.com>
> Date: Tue, 11 Oct 2022 12:38:13 +0200
> Subject: [PATCH] gnu: Add xtrlock.
>
> * gnu/packages/xdisorg.scm (xtrlock): New variable.

Finally applied, with the changes below.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index e4049a5dc2..294a18cdd2 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1164,22 +1164,25 @@  (define-public xtrlock
      ;; LDLIBS are required for the package to build.
      ;; CFLAGS are required for it to use the shadow file, and to
      ;; be compatible with multi-touch devices.
-     '(#:make-flags (list "CFLAGS=-Wall -DSHADOW_PWD -DMULTITOUCH"
-                          "LDLIBS=-lX11 -lcrypt -lXi")
-       #:phases (modify-phases %standard-phases
-                  (delete 'configure)
-                  (delete 'check)
-                  (add-after 'unpack 'rename-makefile
-                    (lambda _
-                      (rename-file "Makefile.noimake" "Makefile")
-                      (rename-file "xtrlock.man" "xtrlock.1")))
-                  (replace 'install
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let* ((out (assoc-ref outputs "out")))
-                        (install-file "xtrlock"
-                                      (string-append out "/bin/"))
-                        (install-file "xtrlock.1"
-                                      (string-append out "/share/man/man1/"))))))))
+     (list #:make-flags
+           #~'("CFLAGS=-O2 -g -Wall -DSHADOW_PWD -DMULTITOUCH"
+               "LDLIBS=-lX11 -lcrypt -lXi")
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)
+               (delete 'check)
+               (add-after 'unpack 'rename-makefile
+                 (lambda _
+                   (rename-file "Makefile.noimake" "Makefile")
+                   (rename-file "xtrlock.man" "xtrlock.1")))
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out")))
+                     (install-file "xtrlock"
+                                   (string-append out "/bin/"))
+                     (install-file "xtrlock.1"
+                                   (string-append out
+                                                  "/share/man/man1/"))))))))
     (inputs (list libx11 libxi libxfixes))
     (home-page "https://packages.debian.org/sid/xtrlock")
     (synopsis "Minimal X display lock program")
@@ -1193,7 +1196,7 @@  (define-public xtrlock
 entered the bell is sounded.  Pressing Backspace or Delete erases one
 character of a password partially typed; pressing Escape or Clear clears
 anything that has been entered.")
-    (license license:gpl3+)))
+    (license license:gpl2+)))
 
 (define-public xosd
   (package