diff mbox series

[bug#66597] gnu: Add sdl2-gamecontrollerdb.

Message ID 87il751590.fsf@pisemsky.com
State New
Headers show
Series [bug#66597] gnu: Add sdl2-gamecontrollerdb. | expand

Commit Message

Evgeny Pisemsky Oct. 17, 2023, 6:19 p.m. UTC

diff mbox series

Patch

From 40688a0f63e85f12a86fa2ccf28fc50150f3846d Mon Sep 17 00:00:00 2001
From: Evgeny Pisemsky <evgeny@pisemsky.com>
Date: Tue, 17 Oct 2023 19:10:10 +0300
Subject: [PATCH] gnu: Add sdl2-gamecontrollerdb.

* gnu/packages/game-development.scm (sdl2-gamecontrollerdb): New variable.
---
 gnu/packages/game-development.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index eb1d74d1e1..3400ca03dc 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 dan <i@dan.games>
 ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -56,6 +57,7 @@  (define-module (gnu packages game-development)
   #:use-module (guix svn-download)
   #:use-module (guix utils)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (guix build-system scons)
@@ -3283,3 +3285,29 @@  (define-public bbcsdl
 allowing you to write utilities and games, use sound and graphics, perform
 calculations and create complete applications.")
     (license license:zlib)))
+
+(define-public sdl2-gamecontrollerdb
+  (let ((commit "6f3c4edcb5a2e2ed090ca8af40d2c0f00dcd77f6")
+        (revision "0"))
+    (package
+      (name "sdl2-gamecontrollerdb")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/gabomdq/SDL_GameControllerDB")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1gciqc8qm2qgcjj5s9jpclznznsp6awl4ldrnj7g01chkcx0l6a3"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan '(("gamecontrollerdb.txt"
+                           "share/sdl2-gamecontrollerdb/"))))
+      (home-page "https://github.com/gabomdq/SDL_GameControllerDB")
+      (synopsis "SDL2 game controller database")
+      (description
+       "A community sourced database of game controller mappings to be used
+with SDL2 Game Controller functionality.")
+      (license license:zlib))))

base-commit: 018567adb7b2d31d0bd457983b755ec3063d08c6
-- 
2.41.0