diff mbox series

[bug#69074] gnu: Add python-pysmt.

Message ID 87il2pbdun.fsf@troyfigiel.com
State New
Headers show
Series [bug#69074] gnu: Add python-pysmt. | expand

Commit Message

Troy Figiel Feb. 12, 2024, 2:58 p.m. UTC
Hi Sören, here an example for python-pysmt, taken from your commit. It might
be good to add a comment why you cannot stick to a fixed version like
0.9.5. Or ask upstream for a new version :-)

* gnu/packages/python-xyz.scm (python-pysmt): New variable.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5fe5c0d60a..bb58e3aaa8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32303,6 +32303,39 @@  (define-public python-opcodes
 and BMI2).")
       (license license:bsd-2))))
 
+(define-public python-pysmt
+  (let ((commit "f7b599c228ee8b429aab1b82ddf167bd956ea8a3")
+        (version "0.9.5")
+        (revision "0"))
+    (package
+      (name "python-pysmt")
+      (version (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/pysmt/pysmt")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "05q70hk9rq3037f999ph5yi1ix4c91db29i17rxwcl6q24vlxiwg"))))
+      (build-system pyproject-build-system)
+      (arguments
+       '(#:phases (modify-phases %standard-phases
+                    (add-before 'check 'set-pysmt-solver
+                      (lambda _
+                        (setenv "PYSMT_SOLVER" "z3"))))))
+      (native-inputs (list python-pytest))
+      (propagated-inputs (list z3))
+      (home-page "https://github.com/pysmt/pysmt")
+      (synopsis
+       "Solver-agnostic library for SMT formula manipulation and solving")
+      (description
+       "This Python module provides a solver-agnostic abstraction for working
+with @acronym{SMT, Satisfiability Modulo Theory} formulas.  For example, it
+allows manipulation and solving such formulas.")
+      (license license:asl2.0))))
+
 (define-public python-rpyc
   (package
     (name "python-rpyc")