[bug#74329,v3,2/8] gnu: Replace quotations with texinfo markup in Perl packages.

Message ID 87ikqsqlee.fsf@erlikon.ch
State New
Headers
Series None |

Commit Message

Gabriel Wicki Jan. 6, 2025, 10:15 a.m. UTC
  * gnu/packages/perl-check.scm (perl-test-object): Fix description.
* gnu/packages/perl.scm (perl-class-load, perl-devel-globaldestruction,
perl-file-which): Fix description.
* gnu/packages/search.scm (perl-search-xapian): Fix description.

Change-Id: Ie3095a597adac82b909591dba64879d9534b2fce
---
 gnu/packages/perl-check.scm |  6 +++---
 gnu/packages/perl.scm       | 12 ++++++------
 gnu/packages/search.scm     |  2 +-
 3 files changed, 10 insertions(+), 10 deletions(-)
  

Patch

diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index e1eb5a0764..1d317d8d2c 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -633,8 +633,8 @@  (define-public perl-test-file-contents
     (home-page "https://metacpan.org/release/Test-File-Contents")
     (synopsis "Test routines for examining the contents of files")
     (description
-     "@{Test::File::Contents} provides functions for testing the contents of
-files.")
+     "@code{Test::File::Contents} provides functions for testing the contents
+of files.")
     (license perl-license)))
 
 (define-public perl-test-file-sharedir
@@ -1177,7 +1177,7 @@  (define-public perl-test-object
 the parent classes.
 
 This should be done to ensure that the implementation of a subclass has not
-somehow ``broken'' the object's behaviour in a more general sense.
+somehow @emph{broken} the object's behaviour in a more general sense.
 
 Test::Object is a testing package designed to allow you to easily test what
 you believe is a valid object against the expected behaviour of all of the
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 773c8f8813..40a64ee4b1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1692,9 +1692,9 @@  (define-public perl-class-load
            perl-module-runtime perl-module-implementation))
     (home-page "https://metacpan.org/release/Class-Load")
     (synopsis "Working (require \"Class::Name\") and more")
-    (description "\"require EXPR\" only accepts Class/Name.pm style module
-names, not Class::Name.  For that, this module provides \"load_class
-'Class::Name'\".")
+    (description "@code{require EXPR} only accepts Class/Name.pm style module
+names, not @code{Class::Name}.  For that, this module provides
+@code{load_class 'Class::Name'}.")
     (license (package-license perl))))
 
 (define-public perl-class-load-xs
@@ -4059,7 +4059,7 @@  (define-public perl-devel-globaldestruction
     (home-page "https://metacpan.org/release/Devel-GlobalDestruction")
     (synopsis "Provides equivalent of ${^GLOBAL_PHASE} eq 'DESTRUCT' for older perls")
     (description "Devel::GlobalDestruction provides a function returning the
-equivalent of \"$@{^GLOBAL_PHASE@} eq 'DESTRUCT'\" for older perls.")
+equivalent of @code{$@{^GLOBAL_PHASE@} eq 'DESTRUCT'} for older perls.")
     (license (package-license perl))))
 
 (define-public perl-devel-hide
@@ -5580,8 +5580,8 @@  (define-public perl-file-which
     (synopsis "Portable implementation of the `which' utility")
     (description
      "File::Which was created to be able to get the paths to executable
-programs on systems under which the `which' program wasn't implemented in the
-shell.")
+programs on systems under which the @command{which} program wasn't implemented
+in the shell.")
     (home-page "https://metacpan.org/release/File-Which")
     (license (package-license perl))))
 
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 1d7f350afd..c580f3bd61 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -195,7 +195,7 @@  (define-public perl-search-xapian
     (description
      "Search::Xapian wraps most methods of most Xapian classes.  The missing
 classes and methods should be added in the future.  It also provides a
-simplified, more 'perlish' interface to some common operations.")
+simplified, more @emph{perlish} interface to some common operations.")
     (license license:perl-license)))
 
 (define-public libtocc