[bug#74329,v3,2/8] gnu: Replace quotations with texinfo markup in Perl packages.
Commit Message
* gnu/packages/perl-check.scm (perl-test-object): Fix description.
* gnu/packages/perl.scm (perl-class-load, perl-devel-globaldestruction,
perl-file-which): Fix description.
* gnu/packages/search.scm (perl-search-xapian): Fix description.
Change-Id: Ie3095a597adac82b909591dba64879d9534b2fce
---
gnu/packages/perl-check.scm | 6 +++---
gnu/packages/perl.scm | 12 ++++++------
gnu/packages/search.scm | 2 +-
3 files changed, 10 insertions(+), 10 deletions(-)
@@ -633,8 +633,8 @@ (define-public perl-test-file-contents
(home-page "https://metacpan.org/release/Test-File-Contents")
(synopsis "Test routines for examining the contents of files")
(description
- "@{Test::File::Contents} provides functions for testing the contents of
-files.")
+ "@code{Test::File::Contents} provides functions for testing the contents
+of files.")
(license perl-license)))
(define-public perl-test-file-sharedir
@@ -1177,7 +1177,7 @@ (define-public perl-test-object
the parent classes.
This should be done to ensure that the implementation of a subclass has not
-somehow ``broken'' the object's behaviour in a more general sense.
+somehow @emph{broken} the object's behaviour in a more general sense.
Test::Object is a testing package designed to allow you to easily test what
you believe is a valid object against the expected behaviour of all of the
@@ -1692,9 +1692,9 @@ (define-public perl-class-load
perl-module-runtime perl-module-implementation))
(home-page "https://metacpan.org/release/Class-Load")
(synopsis "Working (require \"Class::Name\") and more")
- (description "\"require EXPR\" only accepts Class/Name.pm style module
-names, not Class::Name. For that, this module provides \"load_class
-'Class::Name'\".")
+ (description "@code{require EXPR} only accepts Class/Name.pm style module
+names, not @code{Class::Name}. For that, this module provides
+@code{load_class 'Class::Name'}.")
(license (package-license perl))))
(define-public perl-class-load-xs
@@ -4059,7 +4059,7 @@ (define-public perl-devel-globaldestruction
(home-page "https://metacpan.org/release/Devel-GlobalDestruction")
(synopsis "Provides equivalent of ${^GLOBAL_PHASE} eq 'DESTRUCT' for older perls")
(description "Devel::GlobalDestruction provides a function returning the
-equivalent of \"$@{^GLOBAL_PHASE@} eq 'DESTRUCT'\" for older perls.")
+equivalent of @code{$@{^GLOBAL_PHASE@} eq 'DESTRUCT'} for older perls.")
(license (package-license perl))))
(define-public perl-devel-hide
@@ -5580,8 +5580,8 @@ (define-public perl-file-which
(synopsis "Portable implementation of the `which' utility")
(description
"File::Which was created to be able to get the paths to executable
-programs on systems under which the `which' program wasn't implemented in the
-shell.")
+programs on systems under which the @command{which} program wasn't implemented
+in the shell.")
(home-page "https://metacpan.org/release/File-Which")
(license (package-license perl))))
@@ -195,7 +195,7 @@ (define-public perl-search-xapian
(description
"Search::Xapian wraps most methods of most Xapian classes. The missing
classes and methods should be added in the future. It also provides a
-simplified, more 'perlish' interface to some common operations.")
+simplified, more @emph{perlish} interface to some common operations.")
(license license:perl-license)))
(define-public libtocc