bug#74763: [PATCH] gnu: Add python-hdlmake.

Message ID 87ikqqzeky.fsf@gnu.org
State New
Headers
Series bug#74763: [PATCH] gnu: Add python-hdlmake. |

Commit Message

Ludovic Courtès Jan. 7, 2025, 6:03 p.m. UTC
  Cayetano Santos <csantosb@inventati.org> skribis:

> * gnu/packages/fpga.scm (python-hdlmake): New variable.
>
> Change-Id: I4f19d2cceb7fe46bbc359f9bc5197ae3113bb3d7

Applied with the changes below, thanks!
  

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 80d21bab08..c757353ac6 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -36,6 +36,7 @@  (define-module (gnu packages fpga)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages algebra)
@@ -66,6 +67,7 @@  (define-module (gnu packages fpga)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
@@ -764,9 +766,12 @@  (define-public python-hdlmake
       (build-system pyproject-build-system)
       (arguments
        `(#:tests? #f))
+      (native-inputs (list python-setuptools python-wheel))
       (propagated-inputs (list python-six))
       (home-page "https://ohwr.org/projects/hdl-make")
       (synopsis "Generate multi-purpose makefiles for HDL projects")
       (description
-       "Hdlmake helps to manage and share HDL code by automatically finding file dependencies, writing synthesis and simulation Makefiles.")
+       "Hdlmake helps manage and share @acronym{HDL, hardware description
+language} code by automatically finding file dependencies, writing synthesis
+and simulation Makefiles.")
       (license license:gpl3+))))