[bug#77646] gnu: Add r-bigd
Commit Message
Hello!
Please find attached a patch to add bigD from the CRAN.
I have been using this package locally as a dependency for other
packages for a long time, and it works well on my end.
Cheers,
Tor-björn Claesson
From 776b219f3e1291181a9aaf83075791f428282406 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Tor-bj=C3=B6rn=20Claesson?= <tclaesson@gmail.com>
Date: Tue, 8 Apr 2025 11:11:28 +0300
Subject: [PATCH] gnu: Add r-bigd.
* gnu/packages/cran.scm (r-bigd): New variable.
Change-Id: I164034f9823f383628fec5361e6ebeff460c43ec
---
gnu/packages/cran.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)
@@ -39,7 +39,7 @@
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2024 Marco Baggio <guix@mawumag.com>
;;; Copyright © 2024, 2025 Spencer King <spencer.king@geneoscopy.com>
-;;; Copyright © 2024 Tor-björn Claesson <tclaesson@gmail.com>
+;;; Copyright © 2024-2025 Tor-björn Claesson <tclaesson@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -296,6 +296,32 @@ (define-public r-betareg
beta regression, see <doi:10.18637/jss.v048.i11>.")
(license (list license:gpl2 license:gpl3))))
+(define-public r-bigd
+ (package
+ (name "r-bigd")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "bigD" version))
+ (sha256
+ (base32 "1lc8c3g22sb3mkmr0vjw6x92cs04gdfsny1iii0v3xj9337v1cc6"))))
+ (build-system r-build-system)
+ (native-inputs (list r-testthat))
+ (home-page "https://cran.r-project.org/package=bigD")
+ (synopsis "Flexibly Format Dates and Times to a Given Locale")
+ (description
+ "Format dates and times flexibly and to whichever locales
+make sense. Parses dates, times, and date-times in various formats (including
+string-based ISO 8601 constructions). The formatting syntax gives the user
+many options for formatting the date and time output in a precise manner.
+Time zones in the input can be expressed in multiple ways and there are many
+options for formatting time zones in the output as well. Several of the
+provided helper functions allow for automatic generation of locale-aware
+formatting patterns based on date/time skeleton formats and standardized
+date/time formats with varying specificity.")
+ (license license:expat)))
+
(define-public r-bma
(package
(name "r-bma")
--
2.49.0