bug#77930: [PATCH] gnu: Add guile-slugify.
Commit Message
Hi,
Ayush Jha <ayushjha@protonmail.com> writes:
> * gnu/packages/guile-xyz.scm (guile-slugify): New variable.
>
> Change-Id: I4e7ab7a4821f53cf7372388efa07cea2fd3c17ef
> Signed-off-by: Ayush Jha <ayushjha@protonmail.com>
[...]
> + (description
> + "This package provides a procedure for converting strings into URL-friendly
> + slugs. A slug is a simplified version of a string, often used in URLs, that
> + contains only lowercase letters, digits, and hyphens. This package is inspired
> + by the 'slugify' function in the Django web framework. It is useful for
> + generating human-readable identifiers from arbitrary text.")
^
I removed the extra column of whitespace and address minor issues
reported by ‘guix lint’:
Applied, thanks!
Ludo’.
@@ -5507,7 +5507,7 @@ (define-public guile-slugify
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/ayys/guile-slugify.git")
+ (url "https://github.com/ayys/guile-slugify")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -5516,14 +5516,14 @@ (define-public guile-slugify
'("guix.scm" "test.scm")))))
(build-system guile-build-system)
(native-inputs (list guile-3.0))
- (home-page "http://github.com/ayys/slugify.scm")
+ (home-page "https://github.com/ayys/guile-slugify")
(synopsis "Convert arbitrary string to URL-friendly identifier in Guile")
(description
- "This package provides a procedure for converting strings into URL-friendly
-slugs. A slug is a simplified version of a string, often used in URLs, that
-contains only lowercase letters, digits, and hyphens. This package is inspired
-by the 'slugify' function in the Django web framework. It is useful for
-generating human-readable identifiers from arbitrary text.")
+ "This package provides a procedure for converting strings into
+URL-friendly slugs. A slug is a simplified version of a string, often used in
+URLs, that contains only lowercase letters, digits, and hyphens. This package
+is inspired by the @code{slugify} function in the Django web framework. It is
+useful for generating human-readable identifiers from arbitrary text.")
(license license:gpl3+)))
(define-public guile-webutils