bug#33087: [PATCH] gnu: xorg: Add xcb-util-errors.

Message ID 87h8guw66w.fsf@gnu.org
State Accepted
Headers show
Series bug#33087: [PATCH] gnu: xorg: Add xcb-util-errors. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Ludovic Courtès Nov. 6, 2018, 3:56 p.m. UTC
Hello,

Stefan Stefanović <stefanx2ovic@gmail.com> skribis:

> From d99569a104ee893b2b4bd31d7b21d20689405cf2 Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?Stefan=20Stefanovi=C4=87?= <stefanx2ovic@gmail.com>
> Date: Sat, 20 Oct 2018 00:20:25 +0200
> Subject: [PATCH] gnu: Add xcb-util-errors.
>
> * gnu/packages/xorg.scm (xcb-util-errors): New variable.

Applied with the minor changes below, thanks!

Ludo’.

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 7e4fdefe2f..49baef5f04 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5513,6 +5513,9 @@  The XCB util module provides the following libraries:
         (modify-phases %standard-phases
           (replace 'bootstrap
             (lambda _
+              ;; The default 'bootstrap' phase would run 'autogen.sh', which
+              ;; would try to run ./configure and fail due to unpatched
+              ;; shebangs.
               (invoke "autoreconf" "-v" "--install"))))))
      (home-page "https://cgit.freedesktop.org/xcb/util-errors/")
      (synopsis "XCB helper library for printing information about X11 errors")
@@ -5524,12 +5527,10 @@  and interfaces which make the raw X protocol more usable.  Some of the
 libraries also provide client-side code which is not strictly part of
 the X protocol but which has traditionally been provided by Xlib.
 
-The XCB util-errors module provides the following library:
-
-- errors: utility library that gives human readable names to
-error codes, event codes and also to major and minor numbers.")
-     (license (license:non-copyleft
-               "file://COPYING" "See COPYING in the distribution.")))))
+The XCB util-errors module provides a utility library that gives human
+readable names to error codes, event codes, and also to major and minor
+numbers.")
+     (license license:x11))))
 
 (define-public xcb-util-image
   (package