[bug#34851] gnu: Update dtc to 1.5.0.

Message ID 87h8c6bd8x.fsf@ponder
State Accepted
Commit 8cd10b22f9e993cf9375fff10fb937c92ff71017
Headers show
Series [bug#34851] gnu: Update dtc to 1.5.0. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Vagrant Cascadian March 13, 2019, 10:50 p.m. UTC
* gnu/packages/bootloaders (dtc): Update to 1.5.0.
  [native-inputs]: Add libyaml and pkg-config.
---
 gnu/packages/bootloaders.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Ricardo Wurmus March 14, 2019, 10:04 a.m. UTC | #1
Vagrant Cascadian <vagrant@debian.org> writes:

> * gnu/packages/bootloaders (dtc): Update to 1.5.0.
>   [native-inputs]: Add libyaml and pkg-config.

Thanks.  I pushed this with commit 8cd10b22f9.

Patch

diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 15953ab75e..d6ef7d52b5 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -340,7 +340,7 @@  menu to select one of the installed operating systems.")
 (define-public dtc
   (package
     (name "dtc")
-    (version "1.4.7")
+    (version "1.5.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -348,11 +348,13 @@  menu to select one of the installed operating systems.")
                     "dtc-" version ".tar.xz"))
               (sha256
                (base32
-                "1rydi5jvhlhsr110h6n0pavv3daqa0cb4m5vcps50qzq1zqfhhv6"))))
+                "0wh10p42hf5403ipvs0dsxddb6kzfyk2sq4fgid9zqzpr51y8wn6"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)
        ("flex" ,flex)
+       ("libyaml" ,libyaml)
+       ("pkg-config" ,pkg-config)
        ("swig" ,swig)
        ("valgrind" ,valgrind)))
     (inputs