diff mbox series

[bug#37033,v2] gnu: monero: Update to 0.14.1.2.

Message ID 87h86i7h2j.fsf@yamatai
State Accepted
Headers show
Series [bug#37033,v2] gnu: monero: Update to 0.14.1.2. | expand

Commit Message

Guillaume Le Vaillant Aug. 15, 2019, 12:23 p.m. UTC
Efraim Flashner a écrit :

> On Wed, Aug 14, 2019 at 11:30:09PM +0200, Guillaume Le Vaillant wrote:
>> * gnu/packages/finance.scm (monero): Update to 0.14.1.2.
>> ---
>>  gnu/packages/finance.scm | 15 ++++++++-------
>>  1 file changed, 8 insertions(+), 7 deletions(-)
>> 
>>                  "return ((std::string(getenv(\"HOME\"))) / "))
>>               #t))
>> +         (add-after 'change-log-path 'fix-file-permissions-for-tests
>> +           (lambda _
>> +             (for-each (lambda (f)
>> +                         (chmod f #o644))
>> +                       (find-files "tests/data/" "wallet_9svHk1.*"))
>> +             #t))
>>           ;; Only try tests that don't need access to network or system
>>           (replace 'check
>
> Does 'make-file-writable' from (guix build utils) instead of 'chmod'
> work here?

Yes it works. The 'make-file-writable' function is perfect here, I just
didn't know about it. Here's the updated patch:

Comments

Efraim Flashner Aug. 20, 2019, 6:29 a.m. UTC | #1
On Thu, Aug 15, 2019 at 02:23:48PM +0200, Guillaume Le Vaillant wrote:
> 
> Efraim Flashner a écrit :
> 
> >
> > Does 'make-file-writable' from (guix build utils) instead of 'chmod'
> > work here?
> 
> Yes it works. The 'make-file-writable' function is perfect here, I just
> didn't know about it. Here's the updated patch:
> 

That was the plan :)

Patch pushed with minimal changes to the commit message.
diff mbox series

Patch

From 9ec625224313e609c4f3d50b6bd6cf3bb38450a9 Mon Sep 17 00:00:00 2001
From: Guillaume Le Vaillant <glv@posteo.net>
Date: Thu, 15 Aug 2019 14:07:44 +0200
Subject: [PATCH] gnu: monero: Update to 0.14.1.2.

* gnu/packages/finance.scm (monero): Update to 0.14.1.2.
---
 gnu/packages/finance.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7bfe5e62ff..fc26b77279 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -445,7 +445,7 @@  other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
   ;; the system's dynamically linked library.
   (package
     (name "monero")
-    (version "0.14.1.0")
+    (version "0.14.1.2")
     (source
      (origin
        (method git-fetch)
@@ -466,7 +466,7 @@  other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
            #t))
        (sha256
         (base32
-         "1asa197fad81jfv12qgaa7y7pdr1r1pda96m9pvivkh4v30cx0nh"))))
+         "00zl883c7lcd9z7g4y3vv7rxmr7ppzrxdblnhk32r9l3qzyw55r6"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("doxygen" ,doxygen)
@@ -508,6 +508,11 @@  other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
                (("return \\(")
                 "return ((std::string(getenv(\"HOME\"))) / "))
              #t))
+         (add-after 'change-log-path 'fix-file-permissions-for-tests
+           (lambda _
+             (for-each make-file-writable
+                       (find-files "tests/data/" "wallet_9svHk1.*"))
+             #t))
          ;; Only try tests that don't need access to network or system
          (replace 'check
            (lambda _
@@ -522,11 +527,6 @@  other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
                        "DNSResolver.DNSSECSuccess"
                        "DNSResolver.DNSSECFailure"
                        "DNSResolver.GetTXTRecord"
-                       ;; TODO: Find why portability_wallet test fails
-                       ;; Maybe the Boost version used to create the test
-                       ;; wallet and the current Boost version are not
-                       ;; completely compatible?
-                       "Serialization.portability_wallet"
                        "is_hdd.linux_os_root")
                      ":")))
                (invoke "tests/unit_tests/unit_tests"
-- 
2.22.1