diff mbox series

[bug#40128,1/2] gnu: Add emacs-pretty-hydra.

Message ID 87h7xfwa6z.fsf@odyssey.lafreniere.xyz
State Accepted
Headers show
Series [bug#40128,1/2] gnu: Add emacs-pretty-hydra. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph April 19, 2020, 7:24 p.m. UTC
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
> Uh? Did I miss your updated patch?
>
> Would you mind sending it again?

No problem.  :)

Patch file is attached.

--
Joseph LaFreniere

Comments

Christopher Baines Nov. 21, 2020, 9:12 a.m. UTC | #1
LaFreniere, Joseph <joseph@lafreniere.xyz> writes:

> Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
>> Uh? Did I miss your updated patch?
>>
>> Would you mind sending it again?
>
> No problem.  :)
>
> Patch file is attached.

It's been a few months, so I've reviewed and pushed what I think were
the most up to date patches. They're on master as of
90eb5dd6b5989eeb5350c785036c53469496e394.

Thanks,

Chris
diff mbox series

Patch

From bd33f91c6d1b69d9951e9c338b36c92328eb3555 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Wed, 18 Mar 2020 20:59:49 -0500
Subject: [PATCH 1/2] gnu: Add emacs-pretty-hydra.

* gnu/packages/emacs-xyz.scm (emacs-pretty-hydra): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1ea3155807..50eec6d516 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5486,6 +5486,34 @@  the Hydra very seamless; it's like a minor mode that disables itself
 automatically.")
     (license license:gpl3+)))
 
+(define-public emacs-pretty-hydra
+  (package
+    (name "emacs-pretty-hydra")
+    (version "0.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jerrypnz/major-mode-hydra.el.git")
+             (commit version)))
+       (sha256
+        (base32
+         "08a15knkdq35pzjq82imff016fbfdib5q4glg2xmdy2b5fnk7jqa"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-hydra" ,emacs-hydra)
+       ("emacs-s" ,emacs-s)))
+    (arguments
+     `(#:exclude (cons "^major-mode-hydra\\.el" %default-exclude)))
+    (home-page "https://github.com/jerrypnz/major-mode-hydra.el")
+    (synopsis "Major mode keybindings managed by Hydra")
+    (description
+     "This package offers an hydra-based method of managing major
+mode-specific key bindings.  It is intended for use as a library only; see
+package @code{emacs-major-mode-hydra} for a user-friendly interface.")
+    (license license:gpl3+)))
+
 (define-public emacs-ivy
   (package
     (name "emacs-ivy")
-- 
2.25.1