diff mbox series

[bug#40724] sylpheed: New package

Message ID 87h7xftfio.fsf@ericcbrown.com
State Accepted
Headers show
Series [bug#40724] sylpheed: New package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Eric Brown April 19, 2020, 7:57 p.m. UTC
Dear Guix,

Attached is a diff for Syplheed, a graphical email client.

Best regards,
Eric

Comments

Mathieu Othacehe April 26, 2020, 10:51 a.m. UTC | #1
Hello Eric,

Sorry for the late review. I edited a bit the description, changed
the home-page to the HTTPS, english version of the website and pushed.

Thanks,

Mathieu
diff mbox series

Patch

From cb1b5e6af8f118801e00c30a9cee3e76b2a5aa6c Mon Sep 17 00:00:00 2001
From: Eric Brown <ecbrown@ericcbrown.com>
Date: Sun, 19 Apr 2020 14:54:51 -0500
Subject: [PATCH] gnu: Add sylpheed.

* gnu/packages/mail.scm (sylpheed): New variable.
---
 gnu/packages/mail.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d2ec51f27a..a69ec70334 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -31,6 +31,7 @@ 
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
+;;; Copyright © 2020 Eric Brown <ecbrown@ericcbrown.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3181,3 +3182,36 @@  related tools to process winmail.dat files.")
 complement or replace traditional mailing lists.  Readers may read via NNTP,
 Atom feeds or HTML archives.")
      (license agpl3+))))
+
+(define-public sylpheed
+  (package
+    (name "sylpheed")
+    (version "3.7.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://sylpheed.sraoss.jp/sylpheed/v3.7/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0j9y5vdzch251s264diw9clrn88dn20bqqkwfmis9l7m8vmwasqd"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("bogofilter" ,bogofilter)
+       ("compface" ,compface)
+       ("gnupg" ,gnupg-1)
+       ("gpgme" ,gpgme)
+       ("gtk+-2.0" ,gtk+-2)
+       ("gtkspell" ,gtkspell3)
+       ("libnsl" ,libnsl)
+       ("openldap" ,openldap)
+       ("openssl" ,openssl)))
+    (home-page "http://sylpheed.sraoss.jp/")
+    (synopsis "Lightweight GTK+ email client")
+    (description
+     "Sylpheed is a simple, lightweight but featureful, and easy-to-use e-mail
+client. Sylpheed provides intuitive user-interface. Sylpheed is also designed
+for keyboard-oriented operation, so Sylpheed can be widely used from beginners
+to power users.")
+    (license gpl2+)))
-- 
2.26.1