diff mbox series

[bug#47707] gnu: gpodder: Update to 3.10.18.

Message ID 87h7kdxapd.fsf@gmx.com
State Accepted
Headers show
Series [bug#47707] gnu: gpodder: Update to 3.10.18. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pierre Langlois April 11, 2021, 12:33 p.m. UTC
Hi Guix!

Here are a couple of patches to update gpodder, which now uses
python-requests and needs pytest-httpserver to run some HTTP tests.

OK to apply?

Thanks,
Pierre

Comments

M April 11, 2021, 2:46 p.m. UTC | #1
> +       (modify-phases %standard-phases
> +         (add-before 'check 'fix-library-loading
> +           (lambda _
> +             (setenv "PYTHONPATH" (string-append (getenv "PYTHONPATH") ":."))
> +             #t))

Returning #t is not required anymore, please remove.  The warning that results if
a phase doesn't return #t has been removed on core-updates.

No other comments, thanks for updating.
Warning: I haven't tested the patch.

Greetings,
Maxime.
Pierre Langlois April 11, 2021, 2:58 p.m. UTC | #2
Hi Maxime,

Maxime Devos writes:

>> +       (modify-phases %standard-phases
>> +         (add-before 'check 'fix-library-loading
>> +           (lambda _
>> +             (setenv "PYTHONPATH" (string-append (getenv "PYTHONPATH") ":."))
>> +             #t))
>
> Returning #t is not required anymore, please remove.  The warning that results if
> a phase doesn't return #t has been removed on core-updates.

Oh cool, done, going to have to get rid of the habit of adding it :-).

>
> No other comments, thanks for updating.
> Warning: I haven't tested the patch.

Thanks for the review! Pushed with
fca8ef0d765f47faed88100e3c9734cfab3768cd.

Pierre
diff mbox series

Patch

From c65bf4cc07b49dd04009eda3eeaa9056739b3452 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Sun, 11 Apr 2021 13:24:03 +0100
Subject: [PATCH 2/2] gnu: gpodder: Update to 3.10.18.

* gnu/packages/gpodder.scm (gpodder): Update to 3.10.18.
[native-inputs]: Add python-pytest, python-pytest-cov,
python-pytest-httpserver and which.
[inputs]: Add python-requests.
---
 gnu/packages/gpodder.scm | 14 ++++++++++----
 1 file changed, 10 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/gpodder.scm b/gnu/packages/gpodder.scm
index 44c356e2ff..c4dc50c2f9 100644
--- a/gnu/packages/gpodder.scm
+++ b/gnu/packages/gpodder.scm
@@ -1,5 +1,5 @@ 
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2020 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019, 2020, 2021 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -25,6 +25,7 @@ 
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
@@ -38,7 +39,7 @@ 
 (define-public gpodder
   (package
     (name "gpodder")
-    (version "3.10.17")
+    (version "3.10.18")
     (source
      (origin
        (method git-fetch)
@@ -46,18 +47,23 @@ 
              (url "https://github.com/gpodder/gpodder")
              (commit version)))
        (sha256
-        (base32 "0wrk8d4q6ricbcjzlhk10vrk1qg9hi323kgyyd0c8nmh7a82h8pd"))
+        (base32 "1d73q46sqandzbn74nfw9bzzah99z91wsxq2hcivwdgnsv2g2d8y"))
        (file-name (git-file-name name version))
        (patches (search-patches "gpodder-disable-updater.patch"))))
     (build-system python-build-system)
     (native-inputs
      `(("intltool" ,intltool)
        ("python-coverage" ,python-coverage)
-       ("python-minimock" ,python-minimock)))
+       ("python-minimock" ,python-minimock)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-httpserver" ,python-pytest-httpserver)
+       ("which" ,which)))
     (inputs
      `(("gtk+" ,gtk+)
        ("python-pygobject" ,python-pygobject)
        ("python-pycairo" ,python-pycairo)
+       ("python-requests" ,python-requests)
        ("python-dbus" ,python-dbus)
        ("python-html5lib" ,python-html5lib)
        ("python-mygpoclient" ,python-mygpoclient)
-- 
2.31.1