diff mbox

[bug#51508,0/2] Update icedove to 91 branch

Message ID 87h7cxvje1.fsf@netris.org
State Accepted
Headers show

Commit Message

Mark H Weaver Oct. 31, 2021, 5:43 a.m. UTC
Hi Jonathan,

Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:
> One big outstanding issue, is that thunderbird uses now the
> ~/.thunderbird folder for the profiles. I did not get it using
> ~/.icedove like before. So you need to migrate (copy) your profile. I
> can live with that, who can't: have fun finding out how to get back the
> old behaviour :)

Here's a proposed patch that might be what's needed:

--8<---------------cut here---------------start------------->8---
--8<---------------cut here---------------end--------------->8---

Would you like to test it?

       Mark

Comments

Jonathan Brielmaier Oct. 31, 2021, 11:35 a.m. UTC | #1
On 31.10.21 06:43, Mark H Weaver wrote:
> Hi Jonathan,
>
> Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:
>> One big outstanding issue, is that thunderbird uses now the
>> ~/.thunderbird folder for the profiles. I did not get it using
>> ~/.icedove like before. So you need to migrate (copy) your profile. I
>> can live with that, who can't: have fun finding out how to get back the
>> old behaviour :)
>
> Here's a proposed patch that might be what's needed:
>
> --8<---------------cut here---------------start------------->8---
> diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
> index 30b5d6544e..39d67641ff 100644
> --- a/gnu/packages/gnuzilla.scm
> +++ b/gnu/packages/gnuzilla.scm
> @@ -1687,6 +1687,9 @@ standards of the IceCat project.")
>                               "comm/suite/components/customizeToolbar.js")
>                  (("AppConstants.MOZ_APP_NAME (.)= \"thunderbird" _ e)
>                   (format #f "AppConstants.MOZ_APP_NAME ~a= \"icedove" e)))
> +             (substitute* "comm/suite/components/migration/src/nsThunderbirdProfileMigrator.cpp"
> +               (("\"Thunderbird\"") "\"Icedove\"")
> +               (("\"\\.thunderbird\"") "\".icedove\""))
>
>                ;; Override addon URLs and settings
>                (substitute* "comm/mail/app/profile/all-thunderbird.js"
> --8<---------------cut here---------------end--------------->8---
>
> Would you like to test it?

Does not work for me. So icedove still looks up at .thunderbird.
Mark H Weaver Nov. 2, 2021, 2:18 p.m. UTC | #2
Hi,

Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:
> Does not work for me. So icedove still looks up at .thunderbird.

Thanks for testing it.  It didn't work for me either.  I spent some more
time looking for the relevant code, but alas, I wasn't able to find it
in the time available to me.

It would be great if someone else could pick this up.  I can't afford to
spend more time on this in the next few days.

Perhaps someone could ask the Thunderbird developers for clues, or if
all else fails, at least use the Guix news feed functionality to notify
existing Icedove users about the change and what they will need to do.

      Regards,
        Mark
Ludovic Courtès Nov. 13, 2021, 10:06 p.m. UTC | #3
Hi,

Jonathan Brielmaier <jonathan.brielmaier@web.de> skribis:

> Does not work for me. So icedove still looks up at .thunderbird.

Was any of you able to find more clues?

If not, like Mark wrote, better apply the update and add an entry in
etc/news.scm.

Thanks,
Ludo’.
Jonathan Brielmaier Dec. 1, 2021, 10:24 p.m. UTC | #4
On 13.11.21 23:06, Ludovic Courtès wrote:
> If not, like Mark wrote, better apply the update and add an entry in
> etc/news.scm.

I finally did this today. Pushed starting
f1a2e90409622b37b3975cd566c8c0b019e6f7a3.

~Jonathan
pelzflorian (Florian Pelz) Dec. 3, 2021, 10:33 p.m. UTC | #5
On Wed, Dec 01, 2021 at 11:24:44PM +0100, Jonathan Brielmaier wrote:
> On 13.11.21 23:06, Ludovic Courtès wrote:
> > If not, like Mark wrote, better apply the update and add an entry in
> > etc/news.scm.
> 
> I finally did this today. Pushed starting
> f1a2e90409622b37b3975cd566c8c0b019e6f7a3.
> 
> ~Jonathan

Thank you for the update and news entry plus translation!

Will you add your copyright line to etc/news.scm?

Regards,
Florian
Jonathan Brielmaier Dec. 4, 2021, 2:13 p.m. UTC | #6
On 03.12.21 23:33, pelzflorian (Florian Pelz) wrote:
> On Wed, Dec 01, 2021 at 11:24:44PM +0100, Jonathan Brielmaier wrote:
>> On 13.11.21 23:06, Ludovic Courtès wrote:
>>> If not, like Mark wrote, better apply the update and add an entry in
>>> etc/news.scm.
>>
>> I finally did this today. Pushed starting
>> f1a2e90409622b37b3975cd566c8c0b019e6f7a3.
>>
>> ~Jonathan
>
> Thank you for the update and news entry plus translation!

It was a kind of bidirectional translation between English and German :)

> Will you add your copyright line to etc/news.scm?

Ah, good hint. Done in 1e5656e7bd27220ad98a312ff5f293549bfe1912.
diff mbox

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 30b5d6544e..39d67641ff 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1687,6 +1687,9 @@  standards of the IceCat project.")
                             "comm/suite/components/customizeToolbar.js")
                (("AppConstants.MOZ_APP_NAME (.)= \"thunderbird" _ e)
                 (format #f "AppConstants.MOZ_APP_NAME ~a= \"icedove" e)))
+             (substitute* "comm/suite/components/migration/src/nsThunderbirdProfileMigrator.cpp"
+               (("\"Thunderbird\"") "\"Icedove\"")
+               (("\"\\.thunderbird\"") "\".icedove\""))
 
              ;; Override addon URLs and settings
              (substitute* "comm/mail/app/profile/all-thunderbird.js"