diff mbox series

[bug#52299] gnu: Add guile-ini

Message ID 87h7bn79yk.fsf@gmail.com
State Accepted
Headers show
Series [bug#52299] gnu: Add guile-ini | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Artyom V. Poptsov Dec. 5, 2021, 8:05 a.m. UTC
Hello Guixers,

this patch adds Guile-INI -- an INI format[1] parser for GNU Guile.

Guile-INI depends on the recently added Guile-SMC. [2]

Thanks,

- Artyom

References:
1: https://en.wikipedia.org/wiki/INI_file
2: https://guix.gnu.org/en/packages/guile-smc-0.3.0/

Comments

Mathieu Othacehe Dec. 5, 2021, 8:38 a.m. UTC | #1
Hello Artyom,

> +    (synopsis "Guile interface to GitLab")
> +    (description
> +     "This package provides bindings to the GitLab Community Edition REST API
> +as well as the @samp{gitlab-cli} command line tool for interacting with a
> +GitLab instance.")

Looks like you forget to update those fields :).

Mathieu
diff mbox series

Patch

From 490dd30bfb6636818dc60759423e2ee52591682f Mon Sep 17 00:00:00 2001
From: "Artyom V. Poptsov" <poptsov.artyom@gmail.com>
Date: Sun, 5 Dec 2021 11:00:14 +0300
Subject: [PATCH] gnu: Add guile-ini

* gnu/packages/guile-xyz.scm (guile-ini): New variable.
---
 gnu/packages/guile-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 508b4b44d5..67474e4d30 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4944,3 +4944,38 @@  compiler itself.  It produces a Scheme code for an FSM from the PlantUML
 format.  This tool is meant to be called on a PlantUML file when a program
 with a FSM is being built (for example, from a Makefile.)")
     (license license:gpl3)))
+
+(define-public guile-ini
+  (package
+    (name "guile-ini")
+    (version "0.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/artyom-poptsov/guile-ini")
+             (commit (string-append "v" version))))
+       (file-name (string-append name "-" version))
+       (sha256
+        (base32
+         "0injn60530valhx3gsmdp72g6z886yf0n08hscky21h3dafm14kc"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags '("GUILE_AUTO_COMPILE=0")))     ;to prevent guild warnings
+    (native-inputs
+     `(("autoconf"   ,autoconf)
+       ("automake"   ,automake)
+       ("pkg-config" ,pkg-config)
+       ("texinfo"    ,texinfo)))
+    (inputs
+     `(("bash"      ,bash-minimal)
+       ("guile"     ,guile-3.0)
+       ("guile-smc" ,guile-smc)
+       ("guile-lib" ,guile-lib)))
+    (home-page "https://github.com/artyom-poptsov/guile-ini")
+    (synopsis "Guile interface to GitLab")
+    (description
+     "This package provides bindings to the GitLab Community Edition REST API
+as well as the @samp{gitlab-cli} command line tool for interacting with a
+GitLab instance.")
+    (license license:gpl3)))
-- 
2.25.1