diff mbox series

[bug#54078] gnu: add libaml, libneatvnc, and wayvnc

Message ID 87h78ppg0p.fsf_-_@disroot.org
State New
Headers show
Series [bug#54078] gnu: add libaml, libneatvnc, and wayvnc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

kitzman Feb. 23, 2022, 6:57 p.m. UTC
Dear Maxime,

> Is propagation necessary here?  Would regular inputs suffice?
> (Propagation can cause propagation conflicts and other issues.)

That is true, the inputs were wrong.

> ‘Liberally licensed’: the package definition has a 'license' field
> that should be sufficient for the user to determine if they like the
> license or not.  Also, please keep the descriptions descriptive, no
> marketing phrases ‘liberal’, ‘fast, and ‘neat’

Instead of copying the repo's description, now there are some
functionalities of the library. However, it is unknown if they work with
all clients. Do you think it's worth mentioning?
Kind regards,
Kitzman

Comments

M Feb. 23, 2022, 7:15 p.m. UTC | #1
kitzman schreef op wo 23-02-2022 om 20:57 [+0200]:
> Instead of copying the repo's description, now there are some
> functionalities of the library. However, it is unknown if they work
> with
> all clients. Do you think it's worth mentioning?

Different interpretations of the specifications and bugs causing
server-client incompatibilities, and clients not making use of all the
features offered by the server, is always possible.  As such, I don't
think documenting incompatibilities in the description of servers is
very meaningful (YMMV; I would accept a description mentioning
incompatibilities FWIW).

It might be interesting to document these features (or lack of
features) in the descriptions of the clients though.  E.g., encryption
can be very important, so if a client doesn't support that, that might
be good to mention in the description of the package of the client. 
SSH tunneling does not seem to be ‘core’ functionality of VNC but
rather an extra, so that also seems useful to document in the client.

(TBC, this is only superficial review, and I'm not a committer.)

Greetings,
Maxime
kitzman Feb. 23, 2022, 9:02 p.m. UTC | #2
Dear Maxime,

> I don't
> think documenting incompatibilities in the description of servers is
> very meaningful (YMMV; I would accept a description mentioning
> incompatibilities FWIW).

From my perspective, these incompatibilities can be found anyway in the
README, plus it is unknown if some clients go well with the server -
thus one can always try, and maybe open an issue if there's a
problem. So I will leave that out for now.

> (TBC, this is only superficial review, and I'm not a committer.)

Thank you, the problem with the inputs was really bad and the
descriptions now do justice to the server and libs. It will make the
rest of the process much easier.

Kind regards,
Kitzman
diff mbox series

Patch

From c1e8719438ab738193866e0fb43962a7a7117b48 Mon Sep 17 00:00:00 2001
From: kitzman <kitzman@disroot.org>
Date: Wed, 23 Feb 2022 20:46:15 +0200
Subject: [PATCH 2/3] gnu: add libneatvnc

---
 gnu/packages/vnc.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index c0fabe848b..e7b2872074 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2021, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright @ 2022, Kitzman <kitzman@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -39,12 +40,15 @@  (define-module (gnu packages vnc)
   #:use-module (gnu packages fltk)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
+  #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages libevent)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -357,3 +361,27 @@  (define-public libvnc
 easily implement VNC server or client functionality in your program.")
     (license ;; GPL for programs, FDL for documentation
      (list license:gpl2+ license:fdl1.2+))))
+
+(define-public libneatvnc
+  (package
+    (name "libneatvnc")
+    (version "0.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/any1/neatvnc")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "neatvnc" (string-append "v" version)))
+              (sha256
+               (base32
+                "1wpq1vyjqra877vwc3n4i0c1dyhmabyn993cslf1k142ikyc0a8w"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config))
+    (inputs
+     (list libdrm libglvnd libxkbcommon pixman libaml gnutls libjpeg-turbo zlib))
+    (home-page "https://github.com/any1/neatvnc")
+    (synopsis "Lightweight VNC server library")
+    (description "NeatVNC is a lightweight VNC server library, supporting
+authentication, SSH tunneling, and ZRLE or Tight encoding.")
+    (license license:isc)))
+
-- 
2.32.0