diff mbox series

bug#55308: [PATCH 0/2] Packaging kivymd

Message ID 87h75kxebj.fsf_-_@gnu.org
State Accepted
Headers show
Series bug#55308: [PATCH 0/2] Packaging kivymd | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ludovic Courtès May 20, 2022, 6:13 p.m. UTC
Hello,

Ryan Prior <rprior@protonmail.com> skribis:

> * gnu/packages/python-xyz.scm (python-kivymd): New symbol.

Applied both patches, with the changes below on this one (suggested by
‘guix lint’).

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 19daf8cd05..b8fd857fd6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18682,17 +18682,18 @@  (define-public python-kivymd
         (base32 "04lwy6j0agrdwa4a6dl6qs97nx9ysmscmm8psvdzjpyj8aa1zg4p"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f
+     `(#:tests? #f                                ;tests require network
        #:phases
        (modify-phases %standard-phases
          (add-before 'sanity-check 'set-home
            (lambda _
              ;; 'kivy/__init__.py' wants to create $HOME/.kivy.
-             (setenv "HOME" (getcwd)))))))            ; Tests require network
+             (setenv "HOME" (getcwd)))))))
+    (native-inputs (list python-docutils))
     (propagated-inputs
-     (list python-kivy python-pillow python-pygments python-docutils python-kivy-garden))
+     (list python-kivy python-pillow python-pygments python-kivy-garden))
     (home-page "https://github.com/kivymd/KivyMD")
-    (synopsis "A collection of Material Design compliant widgets for use with Kivy")
+    (synopsis "Material Design compliant widgets for use with Kivy")
     (description
      "This package provides Kivy widgets that approximate Google's Material
 Design spec without sacrificing ease of use or application performance.")