@@ -18682,17 +18682,18 @@ (define-public python-kivymd
(base32 "04lwy6j0agrdwa4a6dl6qs97nx9ysmscmm8psvdzjpyj8aa1zg4p"))))
(build-system python-build-system)
(arguments
- `(#:tests? #f
+ `(#:tests? #f ;tests require network
#:phases
(modify-phases %standard-phases
(add-before 'sanity-check 'set-home
(lambda _
;; 'kivy/__init__.py' wants to create $HOME/.kivy.
- (setenv "HOME" (getcwd))))))) ; Tests require network
+ (setenv "HOME" (getcwd)))))))
+ (native-inputs (list python-docutils))
(propagated-inputs
- (list python-kivy python-pillow python-pygments python-docutils python-kivy-garden))
+ (list python-kivy python-pillow python-pygments python-kivy-garden))
(home-page "https://github.com/kivymd/KivyMD")
- (synopsis "A collection of Material Design compliant widgets for use with Kivy")
+ (synopsis "Material Design compliant widgets for use with Kivy")
(description
"This package provides Kivy widgets that approximate Google's Material
Design spec without sacrificing ease of use or application performance.")
Hello, Ryan Prior <rprior@protonmail.com> skribis: > * gnu/packages/python-xyz.scm (python-kivymd): New symbol. Applied both patches, with the changes below on this one (suggested by ‘guix lint’). Thanks! Ludo’.