diff mbox series

[bug#57194] gnu: cmh: Update to 1.1.1.

Message ID 87h71n409x.fsf@aol.com
State Accepted
Headers show
Series [bug#57194] gnu: cmh: Update to 1.1.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hendursaga Sept. 4, 2022, 3:39 p.m. UTC
> I think you need to update gnu/local.mk as well to remove the patch.

Done. Attached you will find the updated patch.

Hendursaga

Comments

Andreas Enge Sept. 12, 2022, 3:38 p.m. UTC | #1
Hello,

Am Sun, Sep 04, 2022 at 11:39:06AM -0400 schrieb Hendursaga:
> > I think you need to update gnu/local.mk as well to remove the patch.
> Done. Attached you will find the updated patch.

thanks a lot, I just pushed it. Apologies for not updating it myself...

Andreas
diff mbox series

Patch

From 5e542036d444f5e482ed9884f60987dab80592f3 Mon Sep 17 00:00:00 2001
From: Hendursaga <hendursaga@aol.com>
Date: Sun, 4 Sep 2022 11:31:29 -0400
Subject: [PATCH] gnu: cmh: Update to 1.1.1.

* gnu/packages/algebra.scm (cmh): Update to 1.1.1.
* gnu/packages/patches/cmh-support-fplll.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
---
 gnu/local.mk                                 |  1 -
 gnu/packages/algebra.scm                     | 47 ++++++++++----------
 gnu/packages/patches/cmh-support-fplll.patch | 27 -----------
 3 files changed, 23 insertions(+), 52 deletions(-)
 delete mode 100644 gnu/packages/patches/cmh-support-fplll.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 1b3225d075..fcc2c0aaa5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -974,7 +974,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/cling-use-shared-library.patch		\
   %D%/packages/patches/clucene-pkgconfig.patch			\
   %D%/packages/patches/cmake-curl-certificates.patch		\
-  %D%/packages/patches/cmh-support-fplll.patch      		\
   %D%/packages/patches/coda-use-system-libs.patch		\
   %D%/packages/patches/collectd-5.11.0-noinstallvar.patch		\
   %D%/packages/patches/containerd-create-pid-file.patch		\
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 8ccb44c434..90aede5fa0 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -293,34 +293,33 @@  (define-public gp2c
 
 (define-public cmh
   (package
-   (name "cmh")
-   (version "1.1.0")
-   (source (origin
-            (method url-fetch)
-            ;; Git repo at <https://gitlab.inria.fr/cmh/cmh>.
-            (uri (string-append "http://www.multiprecision.org/downloads/cmh-"
-                                version ".tar.gz"))
-            (sha256
-             (base32
-              "1ws2yhzxmm2l5xqqqcjcimmg40f9qq5l9i6d4i5434an9v9s8531"))
-             (patches (search-patches "cmh-support-fplll.patch"))))
-   (build-system gnu-build-system)
-   (inputs
-     (list gmp
-           mpfr
-           mpc
-           mpfrcx
-           fplll
-           pari-gp))
-   (synopsis "Igusa class polynomial computations")
-   (description
-    "The CMH software computes Igusa (genus 2) class polynomials, which
+    (name "cmh")
+    (version "1.1.1")
+    (source (origin
+              (method url-fetch)
+              ;; Git repo at <https://gitlab.inria.fr/cmh/cmh>.
+              (uri (string-append
+                    "https://www.multiprecision.org/downloads/cmh-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "0nadvqfmidgks1s7aljsf8dp32pz7vjaxyaym36m9bx4zr8msk91"))))
+    (build-system gnu-build-system)
+    (inputs (list gmp
+                  mpfr
+                  mpc
+                  mpfrcx
+                  fplll
+                  pari-gp))
+    (synopsis "Igusa class polynomial computations")
+    (description
+     "The CMH software computes Igusa (genus 2) class polynomials, which
 parameterize the CM points in the moduli space of 2-dimensional abelian
 varieties, i.e. Jacobians of hyperelliptic curves.
 It can also be used to compute theta constants at arbitrary
 precision.")
-   (license license:gpl3+)
-   (home-page "http://www.multiprecision.org/cmh/home.html")))
+    (license license:gpl3+)
+    (home-page "https://www.multiprecision.org/cmh/home.html")))
 
 (define-public giac
   (package
diff --git a/gnu/packages/patches/cmh-support-fplll.patch b/gnu/packages/patches/cmh-support-fplll.patch
deleted file mode 100644
index fae04f456b..0000000000
--- a/gnu/packages/patches/cmh-support-fplll.patch
+++ /dev/null
@@ -1,27 +0,0 @@ 
-Patch from the CMH git, after the 1.1.0 release.
-
-From 2328c819317dda2171217002268f57c74cedc476 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Emmanuel=20Thom=C3=A9?= <Emmanuel.Thome@inria.fr>
-Date: Tue, 7 Jun 2022 12:17:05 -0700
-Subject: [PATCH] patch suggested by @x-YVicto
-
----
- src/lll.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/lll.cpp b/src/lll.cpp
-index 83dab07..f005931 100644
---- a/src/lll.cpp
-+++ b/src/lll.cpp
-@@ -37,7 +37,7 @@
- #ifdef HAVE_FPLLL
- static void lll_fplll (mpz_t *v, mpz_t **M, const int m, const int n)
- {
--   ZZ_mat <mpz_t> Mp (m, n);
-+   fplll::ZZ_mat <mpz_t> Mp (m, n);
-    int i, j;
- 
-    for (i = 0; i < m; i++)
--- 
-2.36.1
-
-- 
2.37.1