diff mbox series

[bug#63641,7/8] gnu: mig: Update to 04bfe7a91223ba15d868f7165e49328b1c6e86c3.

Message ID 87h6s344yv.fsf@gnu.org
State New
Headers show
Series None | expand

Commit Message

Janneke Nieuwenhuizen May 23, 2023, 12:17 p.m. UTC
Josselin Poiret via Guix-patches via writes:

Hi,

> From: Josselin Poiret <dev@jpoiret.xyz>
>
> * gnu/packages/hurd.scm (mig): Update to
> 04bfe7a91223ba15d868f7165e49328b1c6e86c3.

Did you have a specific reason not to use v1.8+git20230520, or was that
tagged after you created the patch set?  I've tested with that version
(see https://gitlab.com/janneke/guix/-/tree/wip-hurd22) and it seems to
work fine (see attached).

Greetings,
Janneke
diff mbox series

Patch

diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index ae8aff3760..5479940326 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -100,47 +100,45 @@  (define-public gnumach-headers
     (license gpl2+)))
 
 (define-public mig
-  (let ((revision "1")
-        (commit "04bfe7a91223ba15d868f7165e49328b1c6e86c3"))
-    (package
-      (name "mig")
-      (version (git-version "1.8" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://git.savannah.gnu.org/git/hurd/mig.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0zw2w3hnz76f9602znshciqabylmvavx0h04y01qjlmhd9wh8iw5"))))
-      (build-system gnu-build-system)
-      ;; Flex is needed both at build and run time.
-      (inputs (list gnumach-headers flex))
-      (native-inputs (list autoconf automake flex bison))
-      (arguments
-       (list #:tests? #f
-             #:phases
-             #~(modify-phases %standard-phases
-                 (add-after 'install 'avoid-perl-dependency
-                   (lambda* (#:key build inputs outputs #:allow-other-keys)
-                     (let* ((out (assoc-ref outputs "out"))
-                            (bin (string-append out "/bin")))
-                       ;; By default 'mig' (or 'TARGET-mig') uses Perl to
-                       ;; compute 'libexecdir_rel'.  Avoid it.
-                       (substitute* (find-files bin "mig$")
-                         (("^libexecdir_rel=.*")
-                          "libexecdir_rel=../libexec\n"))))))))
-      (home-page "https://www.gnu.org/software/hurd/microkernel/mach/mig/gnu_mig.html")
-      (synopsis "Mach 3.0 interface generator for the Hurd")
-      (description
-       "GNU MIG is the GNU distribution of the Mach 3.0 interface generator
+  (package
+    (name "mig")
+    (version "1.8+git20230520")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.savannah.gnu.org/git/hurd/mig.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "10r0fdjqjzqsy6ajb21rifvhw0wpjvrw6a1zdyliqlzqny5k0qlz"))))
+    (build-system gnu-build-system)
+    ;; Flex is needed both at build and run time.
+    (inputs (list gnumach-headers flex))
+    (native-inputs (list autoconf automake flex bison))
+    (arguments
+     (list #:tests? #f
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'avoid-perl-dependency
+                 (lambda* (#:key build inputs outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out"))
+                          (bin (string-append out "/bin")))
+                     ;; By default 'mig' (or 'TARGET-mig') uses Perl to
+                     ;; compute 'libexecdir_rel'.  Avoid it.
+                     (substitute* (find-files bin "mig$")
+                       (("^libexecdir_rel=.*")
+                        "libexecdir_rel=../libexec\n"))))))))
+    (home-page "https://www.gnu.org/software/hurd/microkernel/mach/mig/gnu_mig.html")
+    (synopsis "Mach 3.0 interface generator for the Hurd")
+    (description
+     "GNU MIG is the GNU distribution of the Mach 3.0 interface generator
 MIG, as maintained by the GNU Hurd developers for the GNU project.
 You need this tool to compile the GNU Mach and GNU Hurd distributions,
 and to compile the GNU C library for the Hurd.  Also, you will need it
 for other software in the GNU system that uses Mach-based inter-process
 communication.")
-      (license gpl2+))))
+    (license gpl2+)))
 
 (define-public hurd-headers
   ;; This commit is now slightly behind 0.9.git20220818 as this one needs a