diff mbox series

[bug#66643,v2] gnu: icedove/wayland: Use escaped "$@" in the executable

Message ID 87h6jjxjcq.fsf@gmail.com
State New
Headers show
Series [bug#66643,v2] gnu: icedove/wayland: Use escaped "$@" in the executable | expand

Commit Message

Aleksandr Vityazev Jan. 12, 2024, 4:32 a.m. UTC
* gnu/packages/gnuzilla (icedove/wayland): Use escaped "$@" in
the executable script.
---
 gnu/packages/gnuzilla.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 188aa02293..7caa044f83 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -2091,7 +2091,7 @@  (define-public icedove/wayland
             (call-with-output-file exe
               (lambda (port)
                 (format port "#!~a
- MOZ_ENABLE_WAYLAND=1 exec ~a $@"
+MOZ_ENABLE_WAYLAND=1 exec ~a \"$@\""
                         #$(file-append bash-minimal "/bin/bash")
                         #$(file-append icedove "/bin/icedove"))))
             (chmod exe #o555)