diff mbox series

[bug#68631] gnu: Add python-sphinx-issues.

Message ID 87h6j7hu49.fsf@troyfigiel.com
State New
Headers show
Series [bug#68631] gnu: Add python-sphinx-issues. | expand

Commit Message

Troy Figiel Jan. 21, 2024, 10:11 a.m. UTC
* gnu/packages/sphinx.scm (python-sphinx-issues): New variable.
---
 gnu/packages/sphinx.scm | 43 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)


base-commit: c79ffe25e98607d6803f960d5187e4098e1dc7c2

Comments

Sharlatan Hellseher Jan. 25, 2024, 8:21 p.m. UTC | #1
Hi,

Thank you for the patch.

It looks good.

> +    (synopsis "Sphinx extension for linking to your project's issue
tracker")

Just one neat pick to synopsis, drop "your": "Sphinx extension for linking
to project's issue tracker"

Nix has 1:1 the same synopsis as on project's GitHub page.
Debian has "your" silent.

Thanks,
Oleg
Troy Figiel Jan. 25, 2024, 8:32 p.m. UTC | #2
Hi Oleg,

I don't mind dropping "your", but grammatically we would need some
article. Something like "Sphinx extension for linking to a project's
issue tracker"? I checked the Debian synopsis and it's grammatically
incorrect, which reads a bit clunky.

Best wishes,

Troy
Troy Figiel Jan. 25, 2024, 10:49 p.m. UTC | #3
Hi Oleg,

- Rebased on master
- "your" -> "a" in the synopsis

Thanks for the review!

Best wishes,

Troy
Sharlatan Hellseher Jan. 26, 2024, 10:16 p.m. UTC | #4
Pushed as 0f646b0ec2b534c7338de5d402a928bc0b46611c to master.

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 7e5a929241..64c97afd8e 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -372,6 +373,48 @@  (define-public python-sphinxcontrib-newsfeed
     (home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
     (license license:bsd-2)))
 
+(define-public python-sphinx-issues
+  (package
+    (name "python-sphinx-issues")
+    (version "4.0.0")
+    (source
+     (origin
+       ;; No tests in the PyPI tarball.
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sloria/sphinx-issues")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0q4as8gibvin0n6h5y1q4cwz3b1nwgs0idfc94dbndx42pjiz1vn"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (add-before 'check 'patch-sphinx-build-path
+                     (lambda _
+                       ;; The path to the sphinx-build binary is hardcoded to
+                       ;; be in the same directory as the python
+                       ;; executable. That does not work when building the
+                       ;; package.
+                       (substitute* "tests/test_sphinx_issues.py"
+                         (((string-append "Path\\(sys\\.executable\\)"
+                                          "\\.parent\\.joinpath\\"
+                                          "(\"sphinx-build\"\\)"))
+                          (string-append "\""
+                                         #$(this-package-native-input
+                                            "python-sphinx")
+                                         "/bin/sphinx-build\""))))))))
+    (native-inputs (list python-flit-core python-pytest python-sphinx))
+    (home-page "https://github.com/sloria/sphinx-issues")
+    (synopsis "Sphinx extension for linking to your project's issue tracker")
+    (description
+     "This package provides a Sphinx extension for linking to your project's
+issue tracker.  This includes roles for linking to issues, pull requests and
+user profiles.  Support for GitHub is built-in, but other services can also be
+supported with @code{sphinx-issues}.")
+    (license license:expat)))
+
 (define-public python-sphinx-panels
   (package
     (name "python-sphinx-panels")