diff mbox series

bug#57387: [PATCH v3] gnu: Add restartd.

Message ID 87h6i5n7pg.fsf@gnu.org
State New
Headers show
Series bug#57387: [PATCH v3] gnu: Add restartd. | expand

Commit Message

Ludovic Courtès Feb. 18, 2024, 2:54 p.m. UTC
Nicolas Graves <ngraves@ngraves.fr> skribis:

> * gnu/packages/admin.scm (restartd): New variable.
> * gnu/packages/patches/restartd-update-robust.patch: Add file.
> * gnu/local.mk: Register gnu/packages/patches/restartd-update-robust.patch.
>
> Change-Id: I38b9b70e97b64f006a86d7618a75f1ec3ed8b034

Applied with the changes below, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9f51427297..47c82e9678 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -5886,12 +5886,13 @@  (define-public restartd
                  (string-append #$output "/share/man/fr/man8/restartd.8")))))))
       (home-page "https://launchpad.net/debian/+source/restartd")
       (synopsis "Daemon for restarting processes")
-      (description "This package provides a daemon for checking running and not
-running processes.  It reads the /proc directory every n seconds and does a
-POSIX regexp on the process names.  The daemon runs an user-provided script
-when it detects a program in the running processes, or an alternate script if
-it doesn't detect the program.  The daemon can only be called by the root
-user, but can use @code{sudo -u user} in the process called if needed.")
+      (description "This package provides a daemon for checking running and
+not running processes.  It reads the @file{/proc} directory every @var{n}
+seconds and does a POSIX regexp on the process names.  The daemon runs a
+user-provided script when it detects a program in the running processes, or an
+alternate script if it doesn't detect the program.  The daemon can only be
+called by the root user, but can use @command{sudo -u user} in the process
+called if needed.")
       (license license:gpl2+))))
 
 (define-public rex